aboutsummaryrefslogtreecommitdiff
path: root/src/service/rest/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/rest/meson.build')
-rw-r--r--src/service/rest/meson.build61
1 files changed, 61 insertions, 0 deletions
diff --git a/src/service/rest/meson.build b/src/service/rest/meson.build
new file mode 100644
index 000000000..1ccb89796
--- /dev/null
+++ b/src/service/rest/meson.build
@@ -0,0 +1,61 @@
1libgnunetrest_src = ['rest.c']
2
3gnunetservicerest_src = ['gnunet-rest-server.c',
4 'config_plugin.c',
5 'copying_plugin.c',
6 'identity_plugin.c',
7 'namestore_plugin.c',
8 'gns_plugin.c',
9 'json_reclaim.c',
10 'reclaim_plugin.c',
11 ]
12
13if jose_dep.found()
14 gnunetservicerest_src += ['oidc_helper.c', 'openid_plugin.c']
15endif
16
17configure_file(input : 'rest.conf',
18 output : 'rest.conf',
19 configuration : cdata,
20 install: true,
21 install_dir: pkgcfgdir)
22
23
24if get_option('monolith')
25 foreach p : libgnunetrest_src + gnunetservicerest_src
26 gnunet_src += 'rest/' + p
27 endforeach
28endif
29
30
31libgnunetrest = library('gnunetrest',
32 libgnunetrest_src,
33 soversion: '0',
34 version: '0.0.0',
35 dependencies: [libgnunetutil_dep, mhd_dep],
36 include_directories: [incdir, configuration_inc],
37 install: true,
38 install_dir: get_option('libdir'))
39pkg.generate(libgnunetrest, url: 'https://www.gnunet.org',
40 description : 'Provides API for accessing the REST service')
41libgnunetrest_dep = declare_dependency(link_with : libgnunetrest)
42
43executable ('gnunet-rest-server',
44 gnunetservicerest_src,
45 dependencies: [libgnunetrest_dep,
46 libgnunetutil_dep,
47 libgnunetidentity_dep,
48 libgnunetgns_dep,
49 libgnunetreclaim_dep,
50 libgnunetnamestore_dep,
51 libgnunetjson_dep,
52 libgnunetgnsrecord_dep,
53 libgnunetgnsrecordjson_dep,
54 json_dep,
55 jose_dep,
56 gcrypt_dep,
57 mhd_dep],
58 include_directories: [incdir, configuration_inc],
59 install: true,
60 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
61