aboutsummaryrefslogtreecommitdiff
path: root/src/service/revocation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/revocation/Makefile.am')
-rw-r--r--src/service/revocation/Makefile.am74
1 files changed, 74 insertions, 0 deletions
diff --git a/src/service/revocation/Makefile.am b/src/service/revocation/Makefile.am
new file mode 100644
index 000000000..18bf21fb0
--- /dev/null
+++ b/src/service/revocation/Makefile.am
@@ -0,0 +1,74 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6if USE_COVERAGE
7 AM_CFLAGS = --coverage -O0
8 XLIB = -lgcov
9endif
10
11pkgcfgdir= $(pkgdatadir)/config.d/
12
13libexecdir= $(pkglibdir)/libexec/
14
15pkgcfg_DATA = \
16 revocation.conf
17
18test_revocation_lsd0001testvectors_SOURCES = \
19 test_revocation_testvectors.c
20test_revocation_lsd0001testvectors_LDADD = \
21 $(top_builddir)/src/service/testing/libgnunettesting.la \
22 $(top_builddir)/src/service/identity/libgnunetidentity.la \
23 libgnunetrevocation.la \
24 $(top_builddir)/src/lib/util/libgnunetutil.la
25
26lib_LTLIBRARIES = libgnunetrevocation.la
27
28libgnunetrevocation_la_SOURCES = \
29 revocation_api.c revocation.h
30libgnunetrevocation_la_LIBADD = \
31 $(top_builddir)/src/lib/util/libgnunetutil.la \
32 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
33 $(LIBGCRYPT_LIBS) \
34 $(GN_LIBINTL) $(XLIB) -lgcrypt
35libgnunetrevocation_la_LDFLAGS = \
36 $(GN_LIB_LDFLAGS) \
37 -version-info 0:0:0
38
39libexec_PROGRAMS = \
40 gnunet-service-revocation
41
42gnunet_service_revocation_SOURCES = \
43 gnunet-service-revocation.c
44gnunet_service_revocation_LDADD = \
45 libgnunetrevocation.la \
46 $(top_builddir)/src/service/core/libgnunetcore.la \
47 $(top_builddir)/src/service/setu/libgnunetsetu.la \
48 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
49 $(top_builddir)/src/lib/gnsrecord/libgnunetgnsrecord.la \
50 $(top_builddir)/src/lib/util/libgnunetutil.la \
51 -lm \
52 $(GN_LIBINTL)
53
54test_revocation_SOURCES = \
55 test_revocation.c
56test_revocation_LDADD = \
57 $(top_builddir)/src/service/identity/libgnunetidentity.la \
58 libgnunetrevocation.la \
59 $(top_builddir)/src//core/libgnunetcore.la \
60 $(top_builddir)/src/lib/util/libgnunetutil.la \
61 $(top_builddir)/src/testbed/libgnunettestbed.la
62
63check_PROGRAMS = \
64 #test_revocation \
65 #test_revocation_lsd0001testvectors
66
67if ENABLE_TEST_RUN
68 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
69 TESTS = \
70 $(check_SCRIPTS) \
71 $(check_PROGRAMS)
72endif
73
74EXTRA_DIST = test_revocation.conf