aboutsummaryrefslogtreecommitdiff
path: root/src/service/revocation/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/revocation/meson.build')
-rw-r--r--src/service/revocation/meson.build44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/service/revocation/meson.build b/src/service/revocation/meson.build
new file mode 100644
index 000000000..57f19f115
--- /dev/null
+++ b/src/service/revocation/meson.build
@@ -0,0 +1,44 @@
1libgnunetrevocation_src = ['revocation_api.c']
2
3gnunetservicerevocation_src = ['gnunet-service-revocation.c']
4
5configure_file(input : 'revocation.conf.in',
6 output : 'revocation.conf',
7 configuration : cdata,
8 install: true,
9 install_dir: pkgcfgdir)
10
11
12if get_option('monolith')
13 foreach p : libgnunetrevocation_src + gnunetservicerevocation_src
14 gnunet_src += 'revocation/' + p
15 endforeach
16endif
17
18libgnunetrevocation = library('gnunetrevocation',
19 libgnunetrevocation_src,
20 soversion: '0',
21 version: '0.0.0',
22 dependencies: [libgnunetutil_dep,
23 libgnunetgnsrecord_dep,
24 libgnunetidentity_dep],
25 include_directories: [incdir, configuration_inc],
26 install: true,
27 install_dir: get_option('libdir'))
28libgnunetrevocation_dep = declare_dependency(link_with : libgnunetrevocation)
29pkg.generate(libgnunetrevocation, url: 'https://www.gnunet.org',
30 description : 'Provides API to perform key revocation in GNUnet')
31
32executable ('gnunet-service-revocation',
33 gnunetservicerevocation_src,
34 dependencies: [libgnunetrevocation_dep,
35 libgnunetutil_dep,
36 libgnunetstatistics_dep,
37 libgnunetcore_dep,
38 libgnunetsetu_dep,
39 libgnunetgnsrecord_dep,
40 libgnunetidentity_dep],
41 include_directories: [incdir, configuration_inc],
42 install: true,
43 install_dir: get_option('libdir')/'gnunet'/'libexec')
44