aboutsummaryrefslogtreecommitdiff
path: root/src/service/topology/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/topology/Makefile.am')
-rw-r--r--src/service/topology/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/service/topology/Makefile.am b/src/service/topology/Makefile.am
new file mode 100644
index 000000000..559e55174
--- /dev/null
+++ b/src/service/topology/Makefile.am
@@ -0,0 +1,47 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12dist_pkgcfg_DATA = \
13 topology.conf
14
15
16libexec_PROGRAMS = \
17 gnunet-daemon-topology
18
19gnunet_daemon_topology_SOURCES = \
20 gnunet-daemon-topology.c
21gnunet_daemon_topology_LDADD = \
22 $(top_builddir)/src/service/core/libgnunetcore.la \
23 $(top_builddir)/src/service/peerstore/libgnunetpeerstore.la \
24 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
25 $(top_builddir)/src/service/transport/libgnunettransportapplication.la \
26 $(top_builddir)/src/lib/hello/libgnunethello.la \
27 $(top_builddir)/src/lib/util/libgnunetutil.la \
28 $(GN_LIBINTL)
29
30
31#check_PROGRAMS = \
32# test_gnunet_daemon_topology
33
34# if ENABLE_TEST_RUN
35# AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
36# TESTS = $(check_PROGRAMS)
37# endif
38
39test_gnunet_daemon_topology_SOURCES = \
40 test_gnunet_daemon_topology.c
41test_gnunet_daemon_topology_LDADD = \
42 $(top_builddir)/src/testbed/libgnunettestbed.la \
43 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
44 $(top_builddir)/src/lib/util/libgnunetutil.la
45
46EXTRA_DIST = \
47 test_gnunet_daemon_topology_data.conf