aboutsummaryrefslogtreecommitdiff
path: root/src/service/topology/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/topology/meson.build')
-rw-r--r--src/service/topology/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/service/topology/meson.build b/src/service/topology/meson.build
new file mode 100644
index 000000000..ca3cc6935
--- /dev/null
+++ b/src/service/topology/meson.build
@@ -0,0 +1,29 @@
1gnunetdaemontopology_src = ['gnunet-daemon-topology.c']
2
3configure_file(input : 'topology.conf',
4 output : 'topology.conf',
5 configuration : cdata,
6 install: true,
7 install_dir: pkgcfgdir)
8
9
10if get_option('monolith')
11 # FIXME add daemon when new daemon macro is ported/ready for it.
12 #foreach p : libgnunetfriends_src
13 # gnunet_src += 'topology/' + p
14 #endforeach
15endif
16
17executable ('gnunet-daemon-topology',
18 gnunetdaemontopology_src,
19 dependencies: [
20 libgnunetutil_dep,
21 libgnunetcore_dep,
22 libgnunetpeerstore_dep,
23 libgnunetstatistics_dep,
24 libgnunettransportapplication_dep,
25 libgnunethello_dep],
26 include_directories: [incdir, configuration_inc],
27 install: true,
28 install_dir: get_option('libdir') / 'gnunet' / 'libexec')
29