aboutsummaryrefslogtreecommitdiff
path: root/src/service/topology/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/topology/meson.build')
-rw-r--r--src/service/topology/meson.build23
1 files changed, 5 insertions, 18 deletions
diff --git a/src/service/topology/meson.build b/src/service/topology/meson.build
index 33b704b41..ca3cc6935 100644
--- a/src/service/topology/meson.build
+++ b/src/service/topology/meson.build
@@ -1,5 +1,3 @@
1libgnunetfriends_src = ['friends.c']
2
3gnunetdaemontopology_src = ['gnunet-daemon-topology.c'] 1gnunetdaemontopology_src = ['gnunet-daemon-topology.c']
4 2
5configure_file(input : 'topology.conf', 3configure_file(input : 'topology.conf',
@@ -10,26 +8,15 @@ configure_file(input : 'topology.conf',
10 8
11 9
12if get_option('monolith') 10if get_option('monolith')
13 foreach p : libgnunetfriends_src 11 # FIXME add daemon when new daemon macro is ported/ready for it.
14 gnunet_src += 'topology/' + p 12 #foreach p : libgnunetfriends_src
15 endforeach 13 # gnunet_src += 'topology/' + p
14 #endforeach
16endif 15endif
17 16
18libgnunetfriends = library('gnunetfriends',
19 libgnunetfriends_src,
20 soversion: '0',
21 version: '0.0.0',
22 dependencies: libgnunetutil_dep,
23 include_directories: [incdir, configuration_inc],
24 install: true,
25 install_dir: get_option('libdir'))
26pkg.generate(libgnunetfriends, url: 'https://www.gnunet.org',
27 description : 'Provides API for accessing the friends service')
28libgnunetfriends_dep = declare_dependency(link_with : libgnunetfriends)
29
30executable ('gnunet-daemon-topology', 17executable ('gnunet-daemon-topology',
31 gnunetdaemontopology_src, 18 gnunetdaemontopology_src,
32 dependencies: [libgnunetfriends_dep, 19 dependencies: [
33 libgnunetutil_dep, 20 libgnunetutil_dep,
34 libgnunetcore_dep, 21 libgnunetcore_dep,
35 libgnunetpeerstore_dep, 22 libgnunetpeerstore_dep,