aboutsummaryrefslogtreecommitdiff
path: root/src/service/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/util/Makefile.am')
-rw-r--r--src/service/util/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/service/util/Makefile.am b/src/service/util/Makefile.am
new file mode 100644
index 000000000..990c2b41d
--- /dev/null
+++ b/src/service/util/Makefile.am
@@ -0,0 +1,50 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4plugindir = $(libdir)/gnunet
5
6libexecdir= $(pkglibdir)/libexec/
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10pkgcfg_DATA = \
11 resolver.conf
12
13if USE_COVERAGE
14 AM_CFLAGS = --coverage -O0
15 XLIB = -lgcov
16endif
17
18libexec_PROGRAMS = \
19 gnunet-service-resolver
20
21if ENABLE_TEST_RUN
22AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
23TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
24endif
25
26gnunet_service_resolver_SOURCES = \
27 gnunet-service-resolver.c
28gnunet_service_resolver_LDADD = \
29 $(top_builddir)/src/lib/util/libgnunetutil.la \
30 $(GN_LIBINTL)
31if HAVE_GETADDRINFO_A
32gnunet_service_resolver_LDADD += -lanl
33endif
34
35
36check_PROGRAMS = \
37 test_resolver_api.nc
38
39# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
40# sequential execution order for them
41TEST_EXTENSIONS = .nc
42test_test_client_unix.log: test_client.log
43
44test_resolver_api_nc_SOURCES = \
45 test_resolver_api.c
46test_resolver_api_nc_LDADD = \
47 $(top_builddir)/src/lib/util/libgnunetutil.la
48
49EXTRA_DIST = \
50 test_resolver_api_data.conf