aboutsummaryrefslogtreecommitdiff
path: root/src/service/vpn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/service/vpn/Makefile.am')
-rw-r--r--src/service/vpn/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/service/vpn/Makefile.am b/src/service/vpn/Makefile.am
new file mode 100644
index 000000000..af500a0b8
--- /dev/null
+++ b/src/service/vpn/Makefile.am
@@ -0,0 +1,53 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3
4if USE_COVERAGE
5 AM_CFLAGS = --coverage -O0
6endif
7
8pkgcfgdir= $(pkgdatadir)/config.d/
9
10libexecdir= $(pkglibdir)/libexec/
11
12plugindir = $(libdir)/gnunet
13
14pkgcfg_DATA = \
15 vpn.conf
16
17if LINUX
18VPNBIN = gnunet-helper-vpn
19endif
20
21
22lib_LTLIBRARIES = \
23 libgnunetvpn.la
24
25
26libexec_PROGRAMS = \
27 $(VPNBIN) \
28 gnunet-service-vpn
29
30gnunet_helper_vpn_SOURCES = \
31 gnunet-helper-vpn.c
32gnunet_helper_vpn_LDADD = \
33 $(top_builddir)/src/lib/util/libgnunetutil.la \
34 $(GN_LIBINTL)
35
36gnunet_service_vpn_SOURCES = \
37 gnunet-service-vpn.c
38gnunet_service_vpn_LDADD = \
39 $(top_builddir)/src/service/statistics/libgnunetstatistics.la \
40 $(top_builddir)/src/lib/util/libgnunetutil.la \
41 $(top_builddir)/src/service/cadet/libgnunetcadet.la \
42 $(top_builddir)/src/service/regex/libgnunetregex.la \
43 $(GN_LIBINTL)
44gnunet_service_vpn_CFLAGS = \
45 -I$(top_srcdir)/src/service/exit $(CFLAGS)
46
47libgnunetvpn_la_SOURCES = \
48 vpn_api.c vpn.h
49libgnunetvpn_la_LIBADD = \
50 $(top_builddir)/src/lib/util/libgnunetutil.la $(XLIB)
51libgnunetvpn_la_LDFLAGS = \
52 $(GN_LIBINTL) \
53 $(GN_LIB_LDFLAGS)