aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index 4d990479c..14667d0ef 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -5,6 +5,8 @@ pkgcfgdir= $(pkgdatadir)/config.d/
5 5
6libexecdir= $(pkglibdir)/libexec/ 6libexecdir= $(pkglibdir)/libexec/
7 7
8plugindir = $(libdir)/gnunet
9
8pkgcfg_DATA = \ 10pkgcfg_DATA = \
9 set.conf 11 set.conf
10 12
@@ -49,7 +51,7 @@ gnunet_set_ibf_profiler_LDADD = \
49 51
50gnunet_service_set_SOURCES = \ 52gnunet_service_set_SOURCES = \
51 gnunet-service-set.c gnunet-service-set.h \ 53 gnunet-service-set.c gnunet-service-set.h \
52 gnunet-service-set_union.c \ 54 gnunet-service-set_union.c gnunet-service-set_union.h \
53 gnunet-service-set_intersection.c \ 55 gnunet-service-set_intersection.c \
54 ibf.c ibf.h \ 56 ibf.c ibf.h \
55 gnunet-service-set_union_strata_estimator.c gnunet-service-set_union_strata_estimator.h \ 57 gnunet-service-set_union_strata_estimator.c gnunet-service-set_union_strata_estimator.h \
@@ -80,7 +82,7 @@ check_PROGRAMS = \
80endif 82endif
81 83
82if ENABLE_TEST_RUN 84if ENABLE_TEST_RUN
83AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 85AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
84TESTS = $(check_PROGRAMS) 86TESTS = $(check_PROGRAMS)
85endif 87endif
86 88
@@ -112,5 +114,19 @@ test_set_union_copy_LDADD = \
112 $(top_builddir)/src/testing/libgnunettesting.la \ 114 $(top_builddir)/src/testing/libgnunettesting.la \
113 libgnunetset.la 115 libgnunetset.la
114 116
117plugin_LTLIBRARIES = \
118 libgnunet_plugin_block_set_test.la
119
120libgnunet_plugin_block_set_test_la_SOURCES = \
121 plugin_block_set_test.c
122libgnunet_plugin_block_set_test_la_LIBADD = \
123 $(top_builddir)/src/block/libgnunetblock.la \
124 $(top_builddir)/src/block/libgnunetblockgroup.la \
125 $(top_builddir)/src/util/libgnunetutil.la \
126 $(LTLIBINTL)
127libgnunet_plugin_block_set_test_la_LDFLAGS = \
128 $(GN_PLUGIN_LDFLAGS)
129
130
115EXTRA_DIST = \ 131EXTRA_DIST = \
116 test_set.conf 132 test_set.conf