aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index 10f7ddc5d..cfe95bc1a 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -5,6 +5,8 @@ pkgcfgdir= $(pkgdatadir)/config.d/
5 5
6libexecdir= $(pkglibdir)/libexec/ 6libexecdir= $(pkglibdir)/libexec/
7 7
8plugindir = $(libdir)/gnunet
9
8pkgcfg_DATA = \ 10pkgcfg_DATA = \
9 set.conf 11 set.conf
10 12
@@ -112,5 +114,19 @@ test_set_union_copy_LDADD = \
112 $(top_builddir)/src/testing/libgnunettesting.la \ 114 $(top_builddir)/src/testing/libgnunettesting.la \
113 libgnunetset.la 115 libgnunetset.la
114 116
117plugin_LTLIBRARIES = \
118 libgnunet_plugin_block_set_test.la
119
120libgnunet_plugin_block_set_test_la_SOURCES = \
121 plugin_block_set_test.c
122libgnunet_plugin_block_set_test_la_LIBADD = \
123 $(top_builddir)/src/block/libgnunetblock.la \
124 $(top_builddir)/src/block/libgnunetblockgroup.la \
125 $(top_builddir)/src/util/libgnunetutil.la \
126 $(LTLIBINTL)
127libgnunet_plugin_block_set_test_la_LDFLAGS = \
128 $(GN_PLUGIN_LDFLAGS)
129
130
115EXTRA_DIST = \ 131EXTRA_DIST = \
116 test_set.conf 132 test_set.conf