aboutsummaryrefslogtreecommitdiff
path: root/src/sq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/sq/Makefile.am')
-rw-r--r--src/sq/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/sq/Makefile.am b/src/sq/Makefile.am
new file mode 100644
index 000000000..7197e7ab4
--- /dev/null
+++ b/src/sq/Makefile.am
@@ -0,0 +1,40 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE
9 AM_CFLAGS = --coverage
10endif
11
12if HAVE_POSTGRESQL
13lib_LTLIBRARIES = libgnunetsq.la
14endif
15
16libgnunetsq_la_SOURCES = \
17 sq.c \
18 sq_query_helper.c \
19 sq_result_helper.c
20libgnunetsq_la_LIBADD = -lsq \
21 $(top_builddir)/src/util/libgnunetutil.la
22libgnunetsq_la_LDFLAGS = \
23 $(POSTGRESQL_LDFLAGS) \
24 $(GN_LIB_LDFLAGS) \
25 -version-info 0:0:0
26
27if ENABLE_TEST_RUN
28TESTS = \
29 test_sq
30endif
31
32check_PROGRAMS= \
33 test_sq
34
35test_sq_SOURCES = \
36 test_sq.c
37test_sq_LDADD = \
38 libgnunetsq.la \
39 $(top_builddir)/src/util/libgnunetutil.la \
40 -lsqlite3 $(XLIB)