aboutsummaryrefslogtreecommitdiff
path: root/src/stream/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/stream/Makefile.am')
-rw-r--r--src/stream/Makefile.am100
1 files changed, 0 insertions, 100 deletions
diff --git a/src/stream/Makefile.am b/src/stream/Makefile.am
deleted file mode 100644
index d21f170be..000000000
--- a/src/stream/Makefile.am
+++ /dev/null
@@ -1,100 +0,0 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12lib_LTLIBRARIES = libgnunetstream.la
13
14libgnunetstream_la_SOURCES = \
15 stream_api.c stream.h
16libgnunetstream_la_LIBADD = \
17 $(top_builddir)/src/mesh/libgnunetmesh.la \
18 $(top_builddir)/src/lockmanager/libgnunetlockmanager.la \
19 $(top_builddir)/src/statistics/libgnunetstatistics.la \
20 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
21libgnunetstream_la_LDFLAGS = \
22 $(GN_LIB_LDFLAGS) \
23 -version-info 1:0:0
24
25if HAVE_BENCHMARKS
26 STREAM_BENCHMARKS = \
27 perf_stream_api
28endif
29
30if HAVE_TESTING
31check_PROGRAMS = \
32 test_stream_2peers \
33 test_stream_2peers_halfclose \
34 test_stream_local \
35 test_stream_big \
36 test_stream_sequence_wraparound \
37 mesh-test \
38 $(STREAM_BENCHMARKS)
39endif
40
41EXTRA_DIST = test_stream_local.conf
42
43if ENABLE_TEST_RUN
44TESTS = \
45 test_stream_2peers \
46 test_stream_2peers_halfclose \
47 test_stream_local \
48 test_stream_big \
49 test_stream_sequence_wraparound \
50 $(STREAM_BENCHMARKS)
51endif
52
53test_stream_2peers_SOURCES = \
54 test_stream_2peers.c
55test_stream_2peers_LDADD = \
56 $(top_builddir)/src/stream/libgnunetstream.la \
57 $(top_builddir)/src/util/libgnunetutil.la \
58 $(top_builddir)/src/testbed/libgnunettestbed.la
59
60
61test_stream_2peers_halfclose_SOURCES = \
62 test_stream_2peers_halfclose.c
63test_stream_2peers_halfclose_LDADD = \
64 $(top_builddir)/src/stream/libgnunetstream.la \
65 $(top_builddir)/src/util/libgnunetutil.la \
66 $(top_builddir)/src/testbed/libgnunettestbed.la
67
68test_stream_local_SOURCES = \
69 test_stream_local.c
70test_stream_local_LDADD = \
71 $(top_builddir)/src/stream/libgnunetstream.la \
72 $(top_builddir)/src/util/libgnunetutil.la \
73 $(top_builddir)/src/testing/libgnunettesting.la
74
75test_stream_big_SOURCES = \
76 test_stream_big.c
77test_stream_big_LDADD = \
78 $(top_builddir)/src/stream/libgnunetstream.la \
79 $(top_builddir)/src/util/libgnunetutil.la \
80 $(top_builddir)/src/testing/libgnunettesting.la
81
82test_stream_sequence_wraparound_SOURCES = \
83 test_stream_sequence_wraparound.c
84test_stream_sequence_wraparound_LDADD = \
85 $(top_builddir)/src/stream/libgnunetstream.la \
86 $(top_builddir)/src/util/libgnunetutil.la \
87 $(top_builddir)/src/testing/libgnunettesting.la
88
89perf_stream_api_SOURCES = \
90 perf_stream_api.c
91perf_stream_api_LDADD = \
92 $(top_builddir)/src/stream/libgnunetstream.la \
93 $(top_builddir)/src/util/libgnunetutil.la \
94 $(top_builddir)/src/testing/libgnunettesting.la \
95 $(top_builddir)/src/testbed/libgnunettestbed.la
96
97mesh_test_SOURCES = mesh-test.c
98mesh_test_LDADD = \
99 $(top_builddir)/src/mesh/libgnunetmesh.la \
100 $(top_builddir)/src/util/libgnunetutil.la