aboutsummaryrefslogtreecommitdiff
path: root/src/template/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/template/Makefile.am')
-rw-r--r--src/template/Makefile.am48
1 files changed, 0 insertions, 48 deletions
diff --git a/src/template/Makefile.am b/src/template/Makefile.am
deleted file mode 100644
index 4d2e58083..000000000
--- a/src/template/Makefile.am
+++ /dev/null
@@ -1,48 +0,0 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include
3
4pkgcfgdir= $(pkgdatadir)/config.d/
5
6libexecdir= $(pkglibdir)/libexec/
7
8dist_pkgcfg_DATA = \
9 template.conf
10
11if USE_COVERAGE
12 AM_CFLAGS = -fprofile-arcs -ftest-coverage
13endif
14
15# Note: In a real installation,
16# bin_PROGRAMS should be used for gnunet-template
17# libexec_PROGRAMS should be used for gnunet-service-template
18
19noinst_PROGRAMS = \
20 gnunet-template \
21 gnunet-service-template
22
23
24gnunet_template_SOURCES = \
25 gnunet-template.c
26gnunet_template_LDADD = \
27 $(top_builddir)/src/util/libgnunetutil.la \
28 $(GN_LIBINTL)
29
30gnunet_service_template_SOURCES = \
31 gnunet-service-template.c
32gnunet_service_template_LDADD = \
33 $(top_builddir)/src/util/libgnunetutil.la \
34 $(GN_LIBINTL)
35
36
37check_PROGRAMS = \
38 test_template_api
39
40if ENABLE_TEST_RUN
41AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
42TESTS = $(check_PROGRAMS)
43endif
44
45test_template_api_SOURCES = \
46 test_template_api.c
47test_template_api_LDADD = \
48 $(top_builddir)/src/util/libgnunetutil.la