aboutsummaryrefslogtreecommitdiff
path: root/src/topology/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/topology/meson.build')
-rw-r--r--src/topology/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/topology/meson.build b/src/topology/meson.build
new file mode 100644
index 000000000..a4f42027c
--- /dev/null
+++ b/src/topology/meson.build
@@ -0,0 +1,27 @@
1libgnunetfriends_src = ['friends.c']
2
3gnunetdaemontopology_src = ['gnunet-daemon-topology.c']
4
5
6if gnunet_monolith == false
7 libgnunetfriends = library('gnunetfriends',
8 libgnunetfriends_src,
9 dependencies: libgnunetutil_dep,
10 include_directories: [incdir, configuration_inc])
11 libgnunetfriends_dep = declare_dependency(link_with : libgnunetfriends)
12 executable ('gnunet-daemon-topology',
13 gnunetdaemontopology_src,
14 dependencies: [libgnunetfriends_dep,
15 libgnunetutil_dep,
16 libgnunetcore_dep,
17 libgnunetpeerinfo_dep,
18 libgnunetstatistics_dep,
19 libgnunettransport_dep,
20 libgnunetats_dep,
21 libgnunethello_dep],
22 include_directories: [incdir, configuration_inc])
23else
24 foreach p : libgnunetfriends_src + gnunetdaemontopology_src
25 gnunet_src += 'topology/' + p
26 endforeach
27endif