aboutsummaryrefslogtreecommitdiff
path: root/src/topology/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/topology/meson.build')
-rw-r--r--src/topology/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/topology/meson.build b/src/topology/meson.build
index a4f42027c..2f1db3641 100644
--- a/src/topology/meson.build
+++ b/src/topology/meson.build
@@ -3,7 +3,7 @@ libgnunetfriends_src = ['friends.c']
3gnunetdaemontopology_src = ['gnunet-daemon-topology.c'] 3gnunetdaemontopology_src = ['gnunet-daemon-topology.c']
4 4
5 5
6if gnunet_monolith == false 6if get_option('monolith') == false
7 libgnunetfriends = library('gnunetfriends', 7 libgnunetfriends = library('gnunetfriends',
8 libgnunetfriends_src, 8 libgnunetfriends_src,
9 dependencies: libgnunetutil_dep, 9 dependencies: libgnunetutil_dep,
@@ -21,7 +21,7 @@ if gnunet_monolith == false
21 libgnunethello_dep], 21 libgnunethello_dep],
22 include_directories: [incdir, configuration_inc]) 22 include_directories: [incdir, configuration_inc])
23else 23else
24 foreach p : libgnunetfriends_src + gnunetdaemontopology_src 24 foreach p : libgnunetfriends_src
25 gnunet_src += 'topology/' + p 25 gnunet_src += 'topology/' + p
26 endforeach 26 endforeach
27endif 27endif