aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 3fae21572..067e882a2 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -201,7 +201,8 @@ check_PROGRAMS = \
201 test_transport_api_reliability_udp \ 201 test_transport_api_reliability_udp \
202 $(HTTP_REL_TEST) \ 202 $(HTTP_REL_TEST) \
203 $(HTTPS_REL_TEST) \ 203 $(HTTPS_REL_TEST) \
204 test_quota_compliance 204 test_quota_compliance_tcp \
205 test_quota_compliance_http
205# TODO: add tests for nat, etc. 206# TODO: add tests for nat, etc.
206 207
207if !DISABLE_TEST_RUN 208if !DISABLE_TEST_RUN
@@ -218,7 +219,8 @@ TESTS = \
218 test_transport_api_reliability_tcp_nat \ 219 test_transport_api_reliability_tcp_nat \
219 $(HTTP_REL_TEST) \ 220 $(HTTP_REL_TEST) \
220 $(HTTPS_REL_TEST) \ 221 $(HTTPS_REL_TEST) \
221 test_quota_compliance 222 test_quota_compliance_tcp \
223 test_quota_compliance_http
222endif 224endif
223 225
224test_transport_api_tcp_SOURCES = \ 226test_transport_api_tcp_SOURCES = \
@@ -305,9 +307,15 @@ test_transport_api_reliability_https_LDADD = \
305 $(top_builddir)/src/transport/libgnunettransport.la \ 307 $(top_builddir)/src/transport/libgnunettransport.la \
306 $(top_builddir)/src/util/libgnunetutil.la 308 $(top_builddir)/src/util/libgnunetutil.la
307 309
308test_quota_compliance_SOURCES = \ 310test_quota_compliance_tcp_SOURCES = \
309 test_quota_compliance.c 311 test_quota_compliance.c
310test_quota_compliance_LDADD = \ 312test_quota_compliance_tcp_LDADD = \
313 $(top_builddir)/src/transport/libgnunettransport.la \
314 $(top_builddir)/src/util/libgnunetutil.la
315
316test_quota_compliance_http_SOURCES = \
317 test_quota_compliance.c
318test_quota_compliance_http_LDADD = \
311 $(top_builddir)/src/transport/libgnunettransport.la \ 319 $(top_builddir)/src/transport/libgnunettransport.la \
312 $(top_builddir)/src/util/libgnunetutil.la 320 $(top_builddir)/src/util/libgnunetutil.la
313 321
@@ -335,5 +343,7 @@ EXTRA_DIST = \
335 test_plugin_transport_data_http.conf \ 343 test_plugin_transport_data_http.conf \
336 test_plugin_transport_data.conf \ 344 test_plugin_transport_data.conf \
337 test_quota_compliance_data.conf \ 345 test_quota_compliance_data.conf \
338 test_quota_compliance_peer1.conf \ 346 test_quota_compliance_tcp_peer1.conf \
339 test_quota_compliance_peer2.conf \ No newline at end of file 347 test_quota_compliance_tcp_peer2.conf \
348 test_quota_compliance_http_peer1.conf \
349 test_quota_compliance_http_peer2.conf \ No newline at end of file