aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am39
1 files changed, 23 insertions, 16 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index c7482f4a8..1cb61c0a9 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -70,7 +70,7 @@ plugin_LTLIBRARIES = \
70 libgnunet_plugin_transport_udp.la \ 70 libgnunet_plugin_transport_udp.la \
71 libgnunet_plugin_transport_udp_nat.la \ 71 libgnunet_plugin_transport_udp_nat.la \
72 libgnunet_plugin_transport_template.la 72 libgnunet_plugin_transport_template.la
73# libgnunet_plugin_transport_http.la 73# libgnunet_plugin_transport_http.la
74# TODO: add http, nat, etc. 74# TODO: add http, nat, etc.
75 75
76libgnunet_plugin_transport_tcp_la_SOURCES = \ 76libgnunet_plugin_transport_tcp_la_SOURCES = \
@@ -110,22 +110,23 @@ libgnunet_plugin_transport_udp_nat_la_LIBADD = \
110libgnunet_plugin_transport_udp_nat_la_LDFLAGS = \ 110libgnunet_plugin_transport_udp_nat_la_LDFLAGS = \
111 $(GN_PLUGIN_LDFLAGS) 111 $(GN_PLUGIN_LDFLAGS)
112 112
113#libgnunet_plugin_transport_http_la_SOURCES = \ 113libgnunet_plugin_transport_http_la_SOURCES = \
114# plugin_transport_http.c 114 plugin_transport_http.c
115#libgnunet_plugin_transport_http_la_LIBADD = \ 115libgnunet_plugin_transport_http_la_LIBADD = \
116# $(top_builddir)/src/hello/libgnunethello.la \ 116 $(top_builddir)/src/hello/libgnunethello.la \
117# $(top_builddir)/src/statistics/libgnunetstatistics.la \ 117 $(top_builddir)/src/statistics/libgnunetstatistics.la \
118# $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 118 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
119# $(top_builddir)/src/util/libgnunetutil.la 119 $(top_builddir)/src/util/libgnunetutil.la
120#libgnunet_plugin_transport_http_la_LDFLAGS = \ 120libgnunet_plugin_transport_http_la_LDFLAGS = \
121# $(GN_PLUGIN_LDFLAGS) 121 $(GN_PLUGIN_LDFLAGS)
122 122
123 123
124check_PROGRAMS = \ 124check_PROGRAMS = \
125 test_transport_api_tcp \ 125 test_transport_api_tcp \
126 test_transport_api_udp \ 126 test_transport_api_udp \
127 test_transport_api_udp_nat \ 127 test_transport_api_udp_nat \
128 test_transport_api_http 128 test_plugin_transport_http
129# test_transport_api_http \
129# TODO: add tests for http, nat, etc. 130# TODO: add tests for http, nat, etc.
130 131
131TESTS = $(check_PROGRAMS) 132TESTS = $(check_PROGRAMS)
@@ -148,12 +149,18 @@ test_transport_api_udp_nat_LDADD = \
148 $(top_builddir)/src/transport/libgnunettransport.la \ 149 $(top_builddir)/src/transport/libgnunettransport.la \
149 $(top_builddir)/src/util/libgnunetutil.la 150 $(top_builddir)/src/util/libgnunetutil.la
150 151
151test_transport_api_http_SOURCES = \ 152#test_transport_api_http_SOURCES = \
152 test_transport_api.c 153# test_transport_api.c
153test_transport_api_http_LDADD = \ 154#test_transport_api_http_LDADD = \
155# $(top_builddir)/src/transport/libgnunettransport.la \
156# $(top_builddir)/src/util/libgnunetutil.la
157
158test_plugin_transport_http_SOURCES = \
159 test_plugin_transport_http.c
160test_plugin_transport_http_LDADD = \
154 $(top_builddir)/src/transport/libgnunettransport.la \ 161 $(top_builddir)/src/transport/libgnunettransport.la \
155 $(top_builddir)/src/util/libgnunetutil.la 162 $(top_builddir)/src/util/libgnunetutil.la
156 163
157 164
158EXTRA_DIST = \ 165EXTRA_DIST = \
159 test_transport_api_data.conf \ 166 test_transport_api_data.conf \
@@ -163,5 +170,5 @@ EXTRA_DIST = \
163 test_transport_api_udp_peer2.conf \ 170 test_transport_api_udp_peer2.conf \
164 test_transport_api_udp_nat_peer1.conf \ 171 test_transport_api_udp_nat_peer1.conf \
165 test_transport_api_udp_nat_peer2.conf \ 172 test_transport_api_udp_nat_peer2.conf \
166 test_plugin_transport_data.conf \ 173 test_plugin_transport_data.conf \
167 test_plugin_transport_data_http.conf 174 test_plugin_transport_data_http.conf