aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am37
1 files changed, 29 insertions, 8 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index a7d49d6e4..a5bf9dbe2 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -18,11 +18,13 @@ if HAVE_MHD
18 HTTP_PLUGIN_TEST = test_plugin_transport_http 18 HTTP_PLUGIN_TEST = test_plugin_transport_http
19 HTTP_API_TEST = test_transport_api_http 19 HTTP_API_TEST = test_transport_api_http
20 HTTP_REL_TEST = test_transport_api_reliability_http 20 HTTP_REL_TEST = test_transport_api_reliability_http
21 HTTP_QUOTA_TEST = test_quota_compliance_http
21 22
22 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la 23 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la
23 HTTPS_PLUGIN_TEST = test_plugin_transport_https 24 HTTPS_PLUGIN_TEST = test_plugin_transport_https
24 HTTPS_API_TEST = test_transport_api_https 25 HTTPS_API_TEST = test_transport_api_https
25 HTTPS_REL_TEST = test_transport_api_reliability_https 26 HTTPS_REL_TEST = test_transport_api_reliability_https
27 HTTPS_QUOTA_TEST = test_quota_compliance_https
26endif 28endif
27 29
28if USE_COVERAGE 30if USE_COVERAGE
@@ -202,9 +204,11 @@ check_PROGRAMS = \
202 $(HTTP_REL_TEST) \ 204 $(HTTP_REL_TEST) \
203 $(HTTPS_REL_TEST) \ 205 $(HTTPS_REL_TEST) \
204 test_quota_compliance_tcp \ 206 test_quota_compliance_tcp \
205 test_quota_compliance_http \ 207 test_quota_compliance_tcp_asymmetric_recv_constant \
206 test_quota_compliance_https \ 208 test_quota_compliance_tcp_asymmetric_send_constant \
207 test_quota_compliance_udp 209 test_quota_compliance_udp \
210 $(HTTP_QUOTA_TEST) \
211 $(HTTPS_QUOTA_TEST)
208# TODO: add tests for nat, etc. 212# TODO: add tests for nat, etc.
209 213
210if !DISABLE_TEST_RUN 214if !DISABLE_TEST_RUN
@@ -222,9 +226,11 @@ TESTS = \
222 $(HTTP_REL_TEST) \ 226 $(HTTP_REL_TEST) \
223 $(HTTPS_REL_TEST) \ 227 $(HTTPS_REL_TEST) \
224 test_quota_compliance_tcp \ 228 test_quota_compliance_tcp \
225 test_quota_compliance_http \ 229 test_quota_compliance_tcp_asymmetric_recv_constant \
226 test_quota_compliance_https \ 230 test_quota_compliance_tcp_asymmetric_send_constant \
227 test_quota_compliance_udp 231 test_quota_compliance_udp \
232 $(HTTP_QUOTA_TEST) \
233 $(HTTPS_QUOTA_TEST)
228endif 234endif
229 235
230test_transport_api_tcp_SOURCES = \ 236test_transport_api_tcp_SOURCES = \
@@ -317,6 +323,18 @@ test_quota_compliance_tcp_LDADD = \
317 $(top_builddir)/src/transport/libgnunettransport.la \ 323 $(top_builddir)/src/transport/libgnunettransport.la \
318 $(top_builddir)/src/util/libgnunetutil.la 324 $(top_builddir)/src/util/libgnunetutil.la
319 325
326test_quota_compliance_tcp_asymmetric_recv_constant_SOURCES = \
327 test_quota_compliance.c
328test_quota_compliance_tcp_asymmetric_recv_constant_LDADD = \
329 $(top_builddir)/src/transport/libgnunettransport.la \
330 $(top_builddir)/src/util/libgnunetutil.la
331
332 test_quota_compliance_tcp_asymmetric_send_constant_SOURCES = \
333 test_quota_compliance.c
334test_quota_compliance_tcp_asymmetric_send_constant_LDADD = \
335 $(top_builddir)/src/transport/libgnunettransport.la \
336 $(top_builddir)/src/util/libgnunetutil.la
337
320test_quota_compliance_http_SOURCES = \ 338test_quota_compliance_http_SOURCES = \
321 test_quota_compliance.c 339 test_quota_compliance.c
322test_quota_compliance_http_LDADD = \ 340test_quota_compliance_http_LDADD = \
@@ -337,6 +355,7 @@ test_quota_compliance_udp_LDADD = \
337 355
338endif 356endif
339 357
358
340EXTRA_DIST = \ 359EXTRA_DIST = \
341 test_transport_api_data.conf \ 360 test_transport_api_data.conf \
342 test_transport_api_tcp_peer1.conf \ 361 test_transport_api_tcp_peer1.conf \
@@ -364,4 +383,6 @@ EXTRA_DIST = \
364 test_quota_compliance_http_peer1.conf \ 383 test_quota_compliance_http_peer1.conf \
365 test_quota_compliance_http_peer2.conf \ 384 test_quota_compliance_http_peer2.conf \
366 test_quota_compliance_https_peer1.conf \ 385 test_quota_compliance_https_peer1.conf \
367 test_quota_compliance_https_peer2.conf \ No newline at end of file 386 test_quota_compliance_https_peer2.conf \
387 test_quota_compliance_udp_peer1.conf \
388 test_quota_compliance_udp_peer2.conf \ No newline at end of file