aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 7d1f89a6e..8d5ea59dd 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -78,19 +78,25 @@ libgnunet_plugin_transport_udp_la_LDFLAGS = \
78 $(GN_PLUGIN_LDFLAGS) 78 $(GN_PLUGIN_LDFLAGS)
79 79
80check_PROGRAMS = \ 80check_PROGRAMS = \
81 test_transport_api \ 81 test_transport_api_tcp \
82 test_transport_api_udp \
82 test_plugin_transport \ 83 test_plugin_transport \
83 test_plugin_transport_udp 84 test_plugin_transport_udp
84# TODO: add tests for tcp, udp, http, nat, etc. 85# TODO: add tests for tcp, udp, http, nat, etc.
85 86
86TESTS = $(check_PROGRAMS) 87TESTS = $(check_PROGRAMS)
87 88
88test_transport_api_SOURCES = \ 89test_transport_api_tcp_SOURCES = \
89 test_transport_api.c 90 test_transport_api.c
90test_transport_api_LDADD = \ 91test_transport_api_tcp_LDADD = \
91 $(top_builddir)/src/transport/libgnunettransport.la \ 92 $(top_builddir)/src/transport/libgnunettransport.la \
92 $(top_builddir)/src/util/libgnunetutil.la 93 $(top_builddir)/src/util/libgnunetutil.la
93 94
95test_transport_api_udp_SOURCES = \
96 test_transport_api.c
97test_transport_api_udp_LDADD = \
98 $(top_builddir)/src/transport/libgnunettransport.la \
99 $(top_builddir)/src/util/libgnunetutil.la
94 100
95test_plugin_transport_SOURCES = \ 101test_plugin_transport_SOURCES = \
96 test_plugin_transport.c 102 test_plugin_transport.c