aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am186
1 files changed, 115 insertions, 71 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index c6fdafa6b..6447b1152 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -10,7 +10,15 @@ pkgcfg_DATA = \
10 10
11if HAVE_MHD 11if HAVE_MHD
12 GN_LIBMHD = -lmicrohttpd 12 GN_LIBMHD = -lmicrohttpd
13 HTTP_PLUGIN_LA = libgnunet_plugin_transport_http.la 13 HTTP_SERVER_PLUGIN_LA = libgnunet_plugin_transport_http_server.la
14 HTTPS_SERVER_PLUGIN_LA = libgnunet_plugin_transport_https_server.la
15endif
16
17HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la
18HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la
19
20
21if FALSE
14 HTTP_API_TEST = test_transport_api_http 22 HTTP_API_TEST = test_transport_api_http
15 HTTP_NAT_API_TEST = test_transport_api_http_nat 23 HTTP_NAT_API_TEST = test_transport_api_http_nat
16 HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http 24 HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http
@@ -18,7 +26,7 @@ if HAVE_MHD
18 HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat 26 HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat
19 HTTP_QUOTA_TEST = test_quota_compliance_http \ 27 HTTP_QUOTA_TEST = test_quota_compliance_http \
20 test_quota_compliance_http_asymmetric 28 test_quota_compliance_http_asymmetric
21 HTTPS_PLUGIN_LA = libgnunet_plugin_transport_https.la 29
22 HTTPS_API_TEST = test_transport_api_https 30 HTTPS_API_TEST = test_transport_api_https
23 HTTPS_NAT_API_TEST = test_transport_api_https_nat 31 HTTPS_NAT_API_TEST = test_transport_api_https_nat
24 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https 32 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
@@ -28,6 +36,7 @@ if HAVE_MHD
28 test_quota_compliance_https_asymmetric 36 test_quota_compliance_https_asymmetric
29endif 37endif
30 38
39
31if USE_COVERAGE 40if USE_COVERAGE
32 AM_CFLAGS = --coverage -O0 41 AM_CFLAGS = --coverage -O0
33endif 42endif
@@ -154,8 +163,10 @@ plugin_LTLIBRARIES = \
154 libgnunet_plugin_transport_tcp.la \ 163 libgnunet_plugin_transport_tcp.la \
155 libgnunet_plugin_transport_udp.la \ 164 libgnunet_plugin_transport_udp.la \
156 $(UNIX_PLUGIN_LA) \ 165 $(UNIX_PLUGIN_LA) \
157 $(HTTP_PLUGIN_LA) \ 166 $(HTTP_CLIENT_PLUGIN_LA) \
158 $(HTTPS_PLUGIN_LA) \ 167 $(HTTPS_CLIENT_PLUGIN_LA) \
168 $(HTTP_SERVER_PLUGIN_LA) \
169 $(HTTPS_SERVER_PLUGIN_LA) \
159 $(WLAN_PLUGIN_LA) \ 170 $(WLAN_PLUGIN_LA) \
160 libgnunet_plugin_transport_template.la 171 libgnunet_plugin_transport_template.la
161 172
@@ -214,43 +225,69 @@ libgnunet_plugin_transport_unix_la_LIBADD = \
214 $(LTLIBINTL) 225 $(LTLIBINTL)
215libgnunet_plugin_transport_unix_la_LDFLAGS = \ 226libgnunet_plugin_transport_unix_la_LDFLAGS = \
216 $(GN_PLUGIN_LDFLAGS) 227 $(GN_PLUGIN_LDFLAGS)
217 228
218libgnunet_plugin_transport_http_la_SOURCES = \ 229
219 plugin_transport_http.c plugin_transport_http.h \ 230libgnunet_plugin_transport_http_client_la_SOURCES = \
220 plugin_transport_http_client.c plugin_transport_http_server.c 231 plugin_transport_http_client.c
221libgnunet_plugin_transport_http_la_LIBADD = \ 232libgnunet_plugin_transport_http_client_la_LIBADD = \
222 $(top_builddir)/src/hello/libgnunethello.la \ 233 $(top_builddir)/src/hello/libgnunethello.la \
223 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 234 $(top_builddir)/src/statistics/libgnunetstatistics.la \
224 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 235 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
225 @LIBCURL@ \ 236 @LIBCURL@ \
226 $(top_builddir)/src/nat/libgnunetnat.la \ 237 $(top_builddir)/src/nat/libgnunetnat.la \
227 $(top_builddir)/src/util/libgnunetutil.la 238 $(top_builddir)/src/util/libgnunetutil.la
228libgnunet_plugin_transport_http_la_LDFLAGS = \ 239libgnunet_plugin_transport_http_client_laLDFLAGS = \
229 $(GN_LIBMHD) \
230 $(GN_PLUGIN_LDFLAGS) 240 $(GN_PLUGIN_LDFLAGS)
231libgnunet_plugin_transport_http_la_CFLAGS = \ 241libgnunet_plugin_transport_http_client_la_CFLAGS = \
232 $(CFLAGS) 242 $(CFLAGS)
233libgnunet_plugin_transport_http_la_CPPFLAGS = \ 243libgnunet_plugin_transport_http_client_la_CPPFLAGS = \
234 @LIBCURL_CPPFLAGS@ 244 @LIBCURL_CPPFLAGS@
245
246
247libgnunet_plugin_transport_http_server_la_SOURCES = \
248 plugin_transport_http_server.c
249libgnunet_plugin_transport_http_server_la_LIBADD = \
250 $(top_builddir)/src/hello/libgnunethello.la \
251 $(top_builddir)/src/statistics/libgnunetstatistics.la \
252 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
253 $(top_builddir)/src/nat/libgnunetnat.la \
254 $(top_builddir)/src/util/libgnunetutil.la
255libgnunet_plugin_transport_http_server_la_LDFLAGS = \
256 $(GN_LIBMHD) \
257 $(GN_PLUGIN_LDFLAGS)
258libgnunet_plugin_transport_http_server_la_CFLAGS = \
259 $(CFLAGS)
235 260
236libgnunet_plugin_transport_https_la_SOURCES = \ 261libgnunet_plugin_transport_https_client_la_SOURCES = \
237 plugin_transport_http.c plugin_transport_http.h \ 262 plugin_transport_http_client.c
238 plugin_transport_http_client.c plugin_transport_http_server.c 263libgnunet_plugin_transport_https_client_la_LIBADD = \
239libgnunet_plugin_transport_https_la_LIBADD = \
240 $(top_builddir)/src/hello/libgnunethello.la \ 264 $(top_builddir)/src/hello/libgnunethello.la \
241 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 265 $(top_builddir)/src/statistics/libgnunetstatistics.la \
242 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 266 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
243 @LIBCURL@ \ 267 @LIBCURL@ \
244 $(top_builddir)/src/nat/libgnunetnat.la \ 268 $(top_builddir)/src/nat/libgnunetnat.la \
245 $(top_builddir)/src/util/libgnunetutil.la 269 $(top_builddir)/src/util/libgnunetutil.la
246libgnunet_plugin_transport_https_la_LDFLAGS = \ 270libgnunet_plugin_transport_https_client_laLDFLAGS = \
247 $(GN_LIBMHD) \
248 $(GN_PLUGIN_LDFLAGS) 271 $(GN_PLUGIN_LDFLAGS)
249libgnunet_plugin_transport_https_la_CFLAGS = \ 272libgnunet_plugin_transport_https_client_la_CFLAGS = \
250 $(CFLAGS) -DBUILD_HTTPS 273 $(CFLAGS)
251libgnunet_plugin_transport_https_la_CPPFLAGS = \ 274libgnunet_plugin_transport_https_client_la_CPPFLAGS = \
252 @LIBCURL_CPPFLAGS@ 275 @LIBCURL_CPPFLAGS@
253 276
277
278libgnunet_plugin_transport_https_server_la_SOURCES = \
279 plugin_transport_http_server.c
280libgnunet_plugin_transport_https_server_la_LIBADD = \
281 $(top_builddir)/src/hello/libgnunethello.la \
282 $(top_builddir)/src/statistics/libgnunetstatistics.la \
283 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
284 $(top_builddir)/src/nat/libgnunetnat.la \
285 $(top_builddir)/src/util/libgnunetutil.la
286libgnunet_plugin_transport_https_server_la_LDFLAGS = \
287 $(GN_LIBMHD) \
288 $(GN_PLUGIN_LDFLAGS)
289libgnunet_plugin_transport_https_server_la_CFLAGS = \
290 $(CFLAGS)
254 291
255check_PROGRAMS = \ 292check_PROGRAMS = \
256 test_transport_testing_startstop \ 293 test_transport_testing_startstop \
@@ -471,22 +508,6 @@ test_transport_api_timeout_unix_LDADD = \
471 $(top_builddir)/src/util/libgnunetutil.la \ 508 $(top_builddir)/src/util/libgnunetutil.la \
472 $(top_builddir)/src/transport/libgnunettransporttesting.la 509 $(top_builddir)/src/transport/libgnunettransporttesting.la
473 510
474test_transport_api_timeout_http_SOURCES = \
475 test_transport_api_timeout.c
476test_transport_api_timeout_http_LDADD = \
477 $(top_builddir)/src/transport/libgnunettransport.la \
478 $(top_builddir)/src/hello/libgnunethello.la \
479 $(top_builddir)/src/util/libgnunetutil.la \
480 $(top_builddir)/src/transport/libgnunettransporttesting.la
481
482test_transport_api_timeout_https_SOURCES = \
483 test_transport_api_timeout.c
484test_transport_api_timeout_https_LDADD = \
485 $(top_builddir)/src/transport/libgnunettransport.la \
486 $(top_builddir)/src/hello/libgnunethello.la \
487 $(top_builddir)/src/util/libgnunetutil.la \
488 $(top_builddir)/src/transport/libgnunettransporttesting.la
489
490test_transport_api_reliability_tcp_nat_SOURCES = \ 511test_transport_api_reliability_tcp_nat_SOURCES = \
491 test_transport_api_reliability.c 512 test_transport_api_reliability.c
492test_transport_api_reliability_tcp_nat_LDADD = \ 513test_transport_api_reliability_tcp_nat_LDADD = \
@@ -543,6 +564,26 @@ test_transport_api_unix_LDADD = \
543 $(top_builddir)/src/util/libgnunetutil.la \ 564 $(top_builddir)/src/util/libgnunetutil.la \
544 $(top_builddir)/src/transport/libgnunettransporttesting.la 565 $(top_builddir)/src/transport/libgnunettransporttesting.la
545 566
567# HTTP/S tests
568if FALSE
569
570test_transport_api_timeout_http_SOURCES = \
571 test_transport_api_timeout.c
572test_transport_api_timeout_http_LDADD = \
573 $(top_builddir)/src/transport/libgnunettransport.la \
574 $(top_builddir)/src/hello/libgnunethello.la \
575 $(top_builddir)/src/util/libgnunetutil.la \
576 $(top_builddir)/src/transport/libgnunettransporttesting.la
577
578test_transport_api_timeout_https_SOURCES = \
579 test_transport_api_timeout.c
580test_transport_api_timeout_https_LDADD = \
581 $(top_builddir)/src/transport/libgnunettransport.la \
582 $(top_builddir)/src/hello/libgnunethello.la \
583 $(top_builddir)/src/util/libgnunetutil.la \
584 $(top_builddir)/src/transport/libgnunettransporttesting.la
585
586
546test_transport_api_http_SOURCES = \ 587test_transport_api_http_SOURCES = \
547 test_transport_api.c 588 test_transport_api.c
548test_transport_api_http_LDADD = \ 589test_transport_api_http_LDADD = \
@@ -607,6 +648,41 @@ test_transport_api_reliability_https_nat_LDADD = \
607 $(top_builddir)/src/util/libgnunetutil.la \ 648 $(top_builddir)/src/util/libgnunetutil.la \
608 $(top_builddir)/src/transport/libgnunettransporttesting.la 649 $(top_builddir)/src/transport/libgnunettransporttesting.la
609 650
651test_quota_compliance_http_SOURCES = \
652 test_quota_compliance.c
653test_quota_compliance_http_LDADD = \
654 $(top_builddir)/src/transport/libgnunettransport.la \
655 $(top_builddir)/src/hello/libgnunethello.la \
656 $(top_builddir)/src/util/libgnunetutil.la \
657 $(top_builddir)/src/transport/libgnunettransporttesting.la
658
659test_quota_compliance_http_asymmetric_SOURCES = \
660 test_quota_compliance.c
661test_quota_compliance_http_asymmetric_LDADD = \
662 $(top_builddir)/src/transport/libgnunettransport.la \
663 $(top_builddir)/src/hello/libgnunethello.la \
664 $(top_builddir)/src/util/libgnunetutil.la \
665 $(top_builddir)/src/transport/libgnunettransporttesting.la
666
667test_quota_compliance_https_SOURCES = \
668 test_quota_compliance.c
669test_quota_compliance_https_LDADD = \
670 $(top_builddir)/src/transport/libgnunettransport.la \
671 $(top_builddir)/src/hello/libgnunethello.la \
672 $(top_builddir)/src/util/libgnunetutil.la \
673 $(top_builddir)/src/transport/libgnunettransporttesting.la
674
675test_quota_compliance_https_asymmetric_SOURCES = \
676 test_quota_compliance.c
677test_quota_compliance_https_asymmetric_LDADD = \
678 $(top_builddir)/src/transport/libgnunettransport.la \
679 $(top_builddir)/src/hello/libgnunethello.la \
680 $(top_builddir)/src/util/libgnunetutil.la \
681 $(top_builddir)/src/transport/libgnunettransporttesting.la
682
683
684endif
685
610test_transport_api_unreliability_unix_SOURCES = \ 686test_transport_api_unreliability_unix_SOURCES = \
611 test_transport_api_unreliability.c 687 test_transport_api_unreliability.c
612test_transport_api_unreliability_unix_LDADD = \ 688test_transport_api_unreliability_unix_LDADD = \
@@ -657,38 +733,6 @@ test_quota_compliance_tcp_asymmetric_LDADD = \
657 $(top_builddir)/src/util/libgnunetutil.la \ 733 $(top_builddir)/src/util/libgnunetutil.la \
658 $(top_builddir)/src/transport/libgnunettransporttesting.la 734 $(top_builddir)/src/transport/libgnunettransporttesting.la
659 735
660test_quota_compliance_http_SOURCES = \
661 test_quota_compliance.c
662test_quota_compliance_http_LDADD = \
663 $(top_builddir)/src/transport/libgnunettransport.la \
664 $(top_builddir)/src/hello/libgnunethello.la \
665 $(top_builddir)/src/util/libgnunetutil.la \
666 $(top_builddir)/src/transport/libgnunettransporttesting.la
667
668test_quota_compliance_http_asymmetric_SOURCES = \
669 test_quota_compliance.c
670test_quota_compliance_http_asymmetric_LDADD = \
671 $(top_builddir)/src/transport/libgnunettransport.la \
672 $(top_builddir)/src/hello/libgnunethello.la \
673 $(top_builddir)/src/util/libgnunetutil.la \
674 $(top_builddir)/src/transport/libgnunettransporttesting.la
675
676test_quota_compliance_https_SOURCES = \
677 test_quota_compliance.c
678test_quota_compliance_https_LDADD = \
679 $(top_builddir)/src/transport/libgnunettransport.la \
680 $(top_builddir)/src/hello/libgnunethello.la \
681 $(top_builddir)/src/util/libgnunetutil.la \
682 $(top_builddir)/src/transport/libgnunettransporttesting.la
683
684test_quota_compliance_https_asymmetric_SOURCES = \
685 test_quota_compliance.c
686test_quota_compliance_https_asymmetric_LDADD = \
687 $(top_builddir)/src/transport/libgnunettransport.la \
688 $(top_builddir)/src/hello/libgnunethello.la \
689 $(top_builddir)/src/util/libgnunetutil.la \
690 $(top_builddir)/src/transport/libgnunettransporttesting.la
691
692test_quota_compliance_udp_SOURCES = \ 736test_quota_compliance_udp_SOURCES = \
693 test_quota_compliance.c 737 test_quota_compliance.c
694test_quota_compliance_udp_LDADD = \ 738test_quota_compliance_udp_LDADD = \