aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index b8d220e72..c89e6d42f 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -4,6 +4,8 @@ plugindir = $(libdir)/gnunet
4 4
5pkgcfgdir= $(pkgdatadir)/config.d/ 5pkgcfgdir= $(pkgdatadir)/config.d/
6 6
7libexecdir= $(pkglibdir)/libexec/
8
7pkgcfg_DATA = \ 9pkgcfg_DATA = \
8 transport.conf 10 transport.conf
9 11
@@ -59,7 +61,7 @@ endif
59 61
60if LINUX 62if LINUX
61install-exec-hook: 63install-exec-hook:
62 $(top_srcdir)/src/transport/install-wlan-helper.sh $(bindir) $(SUDO_BINARY) || true 64 $(top_srcdir)/src/transport/install-wlan-helper.sh $(libexecdir) $(SUDO_BINARY) || true
63else 65else
64install-exec-hook: 66install-exec-hook:
65endif 67endif
@@ -107,11 +109,13 @@ libgnunettransport_la_LDFLAGS = \
107 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 109 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
108 -version-info 1:0:0 110 -version-info 1:0:0
109 111
110bin_PROGRAMS = \ 112libexec_PROGRAMS = \
111 gnunet-transport \
112 $(WLAN_BIN) \ 113 $(WLAN_BIN) \
113 $(WLAN_BIN_DUMMY) \ 114 $(WLAN_BIN_DUMMY) \
114 gnunet-service-transport \ 115 gnunet-service-transport
116
117bin_PROGRAMS = \
118 gnunet-transport \
115 gnunet-transport-certificate-creation 119 gnunet-transport-certificate-creation
116 120
117#bin_SCRIPTS = \ 121#bin_SCRIPTS = \