aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index db528d80c..339e58bed 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -34,11 +34,12 @@ endif
34 34
35if HAVE_PCAP 35if HAVE_PCAP
36if LINUX 36if LINUX
37if HAVE_EXPERIMENTAL 37#if HAVE_EXPERIMENTAL
38 WANBIN = gnunet-transport-wlan-helper 38 WANBIN = gnunet-transport-wlan-helper
39 WLAN_PLUGIN_LA = libgnunet_plugin_transport_wlan.la 39 WLAN_PLUGIN_LA = libgnunet_plugin_transport_wlan.la
40 WLAN_API_TEST = test_transport_api_wlan 40 WLAN_API_TEST = test_transport_api_wlan
41endif 41 WLAN_REL_TEST = test_transport_api_reliability_wlan
42#endif
42endif 43endif
43endif 44endif
44 45
@@ -212,6 +213,7 @@ check_PROGRAMS = \
212 $(HTTPS_PLUGIN_TEST) \ 213 $(HTTPS_PLUGIN_TEST) \
213 $(HTTPS_API_TEST) \ 214 $(HTTPS_API_TEST) \
214 $(WLAN_API_TEST) \ 215 $(WLAN_API_TEST) \
216 $(WLAN_REL_TEST) \
215 test_transport_api_multi \ 217 test_transport_api_multi \
216 test_transport_api_reliability_tcp \ 218 test_transport_api_reliability_tcp \
217 test_transport_api_reliability_tcp_nat \ 219 test_transport_api_reliability_tcp_nat \
@@ -285,6 +287,14 @@ test_transport_api_reliability_tcp_nat_LDADD = \
285 $(top_builddir)/src/hello/libgnunethello.la \ 287 $(top_builddir)/src/hello/libgnunethello.la \
286 $(top_builddir)/src/util/libgnunetutil.la 288 $(top_builddir)/src/util/libgnunetutil.la
287 289
290test_transport_api_reliability_wlan_SOURCES = \
291 test_transport_api_reliability.c
292test_transport_api_reliability_wlan_LDADD = \
293 $(top_builddir)/src/transport/libgnunettransport.la \
294 $(top_builddir)/src/hello/libgnunethello.la \
295 $(top_builddir)/src/util/libgnunetutil.la
296
297
288test_transport_api_udp_SOURCES = \ 298test_transport_api_udp_SOURCES = \
289 test_transport_api.c 299 test_transport_api.c
290test_transport_api_udp_LDADD = \ 300test_transport_api_udp_LDADD = \