aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am41
1 files changed, 9 insertions, 32 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 9cf16ddb6..2865460fd 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -155,6 +155,7 @@ endif
155lib_LTLIBRARIES = \ 155lib_LTLIBRARIES = \
156 libgnunettransport.la \ 156 libgnunettransport.la \
157 libgnunettransportaddress.la \ 157 libgnunettransportaddress.la \
158 libgnunettransportapplication.la \
158 libgnunettransportcore.la \ 159 libgnunettransportcore.la \
159 libgnunettransportcommunicator.la \ 160 libgnunettransportcommunicator.la \
160 libgnunettransportmonitor.la \ 161 libgnunettransportmonitor.la \
@@ -196,6 +197,14 @@ libgnunettransport_la_LDFLAGS = \
196 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 197 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
197 -version-info 4:0:2 198 -version-info 4:0:2
198 199
200libgnunettransportapplication_la_SOURCES = \
201 transport_api2_application.c
202libgnunettransportapplication_la_LIBADD = \
203 $(top_builddir)/src/util/libgnunetutil.la \
204 $(LTLIBINTL)
205libgnunettransportapplication_la_LDFLAGS = \
206 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
207 -version-info 0:0:0
199 208
200 209
201libgnunettransportaddress_la_SOURCES = \ 210libgnunettransportaddress_la_SOURCES = \
@@ -360,7 +369,6 @@ gnunet_service_transport_CFLAGS = \
360gnunet_service_tng_SOURCES = \ 369gnunet_service_tng_SOURCES = \
361 gnunet-service-tng.c 370 gnunet-service-tng.c
362gnunet_service_tng_LDADD = \ 371gnunet_service_tng_LDADD = \
363 $(top_builddir)/src/ats/libgnunetatstransport.la \
364 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 372 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
365 $(top_builddir)/src/hello/libgnunethello.la \ 373 $(top_builddir)/src/hello/libgnunethello.la \
366 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 374 $(top_builddir)/src/statistics/libgnunetstatistics.la \
@@ -378,12 +386,6 @@ plugin_LTLIBRARIES = \
378 $(WLAN_PLUGIN_LA) \ 386 $(WLAN_PLUGIN_LA) \
379 $(BT_PLUGIN_LA) 387 $(BT_PLUGIN_LA)
380 388
381if HAVE_EXPERIMENTAL
382plugin_LTLIBRARIES += \
383 libgnunet_plugin_transport_xt.la \
384 libgnunet_plugin_transport_xu.la
385endif
386
387# Note: real plugins of course need to be added 389# Note: real plugins of course need to be added
388# to the plugin_LTLIBRARIES above 390# to the plugin_LTLIBRARIES above
389noinst_LTLIBRARIES = \ 391noinst_LTLIBRARIES = \
@@ -401,18 +403,6 @@ libgnunet_plugin_transport_tcp_la_LIBADD = \
401libgnunet_plugin_transport_tcp_la_LDFLAGS = \ 403libgnunet_plugin_transport_tcp_la_LDFLAGS = \
402 $(GN_PLUGIN_LDFLAGS) 404 $(GN_PLUGIN_LDFLAGS)
403 405
404libgnunet_plugin_transport_xt_la_SOURCES = \
405 plugin_transport_xt.c
406libgnunet_plugin_transport_xt_la_LIBADD = \
407 $(top_builddir)/src/hello/libgnunethello.la \
408 $(top_builddir)/src/statistics/libgnunetstatistics.la \
409 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
410 $(top_builddir)/src/nat/libgnunetnatnew.la \
411 $(top_builddir)/src/util/libgnunetutil.la \
412 $(LTLIBINTL)
413libgnunet_plugin_transport_xt_la_LDFLAGS = \
414 $(GN_PLUGIN_LDFLAGS)
415
416libgnunet_plugin_transport_template_la_SOURCES = \ 406libgnunet_plugin_transport_template_la_SOURCES = \
417 plugin_transport_template.c 407 plugin_transport_template.c
418libgnunet_plugin_transport_template_la_LIBADD = \ 408libgnunet_plugin_transport_template_la_LIBADD = \
@@ -461,19 +451,6 @@ libgnunet_plugin_transport_udp_la_LIBADD = \
461libgnunet_plugin_transport_udp_la_LDFLAGS = \ 451libgnunet_plugin_transport_udp_la_LDFLAGS = \
462 $(GN_PLUGIN_LDFLAGS) 452 $(GN_PLUGIN_LDFLAGS)
463 453
464libgnunet_plugin_transport_xu_la_SOURCES = \
465 plugin_transport_xu.c plugin_transport_xu.h
466libgnunet_plugin_transport_xu_la_LIBADD = \
467 $(top_builddir)/src/hello/libgnunethello.la \
468 $(top_builddir)/src/fragmentation/libgnunetfragmentation.la \
469 $(top_builddir)/src/statistics/libgnunetstatistics.la \
470 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
471 $(top_builddir)/src/nat/libgnunetnatnew.la \
472 $(top_builddir)/src/util/libgnunetutil.la \
473 $(LTLIBINTL)
474libgnunet_plugin_transport_xu_la_LDFLAGS = \
475 $(GN_PLUGIN_LDFLAGS)
476
477libgnunet_plugin_transport_unix_la_SOURCES = \ 454libgnunet_plugin_transport_unix_la_SOURCES = \
478 plugin_transport_unix.c 455 plugin_transport_unix.c
479libgnunet_plugin_transport_unix_la_LIBADD = \ 456libgnunet_plugin_transport_unix_la_LIBADD = \