aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 1cb61c0a9..c6f2bc2ff 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -6,6 +6,12 @@ if MINGW
6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
7endif 7endif
8 8
9if HAVE_MHD
10 GN_LIBMHD = -lmicrohttpd
11 HTTP_PLUGIN_LA = libgnunet_plugin_transport_http.la
12 HTTP_PLGUIN_CHECK = test_plugin_transport_http
13endif
14
9if USE_COVERAGE 15if USE_COVERAGE
10 AM_CFLAGS = --coverage -O0 16 AM_CFLAGS = --coverage -O0
11endif 17endif
@@ -69,8 +75,8 @@ plugin_LTLIBRARIES = \
69 libgnunet_plugin_transport_tcp.la \ 75 libgnunet_plugin_transport_tcp.la \
70 libgnunet_plugin_transport_udp.la \ 76 libgnunet_plugin_transport_udp.la \
71 libgnunet_plugin_transport_udp_nat.la \ 77 libgnunet_plugin_transport_udp_nat.la \
78 $(HTTP_PLUGIN_LA) \
72 libgnunet_plugin_transport_template.la 79 libgnunet_plugin_transport_template.la
73# libgnunet_plugin_transport_http.la
74# TODO: add http, nat, etc. 80# TODO: add http, nat, etc.
75 81
76libgnunet_plugin_transport_tcp_la_SOURCES = \ 82libgnunet_plugin_transport_tcp_la_SOURCES = \
@@ -110,6 +116,7 @@ libgnunet_plugin_transport_udp_nat_la_LIBADD = \
110libgnunet_plugin_transport_udp_nat_la_LDFLAGS = \ 116libgnunet_plugin_transport_udp_nat_la_LDFLAGS = \
111 $(GN_PLUGIN_LDFLAGS) 117 $(GN_PLUGIN_LDFLAGS)
112 118
119if HAVE_MHD
113libgnunet_plugin_transport_http_la_SOURCES = \ 120libgnunet_plugin_transport_http_la_SOURCES = \
114 plugin_transport_http.c 121 plugin_transport_http.c
115libgnunet_plugin_transport_http_la_LIBADD = \ 122libgnunet_plugin_transport_http_la_LIBADD = \
@@ -118,14 +125,15 @@ libgnunet_plugin_transport_http_la_LIBADD = \
118 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 125 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
119 $(top_builddir)/src/util/libgnunetutil.la 126 $(top_builddir)/src/util/libgnunetutil.la
120libgnunet_plugin_transport_http_la_LDFLAGS = \ 127libgnunet_plugin_transport_http_la_LDFLAGS = \
128 $(GN_LIBMHD) \
121 $(GN_PLUGIN_LDFLAGS) 129 $(GN_PLUGIN_LDFLAGS)
122 130endif
123 131
124check_PROGRAMS = \ 132check_PROGRAMS = \
125 test_transport_api_tcp \ 133 test_transport_api_tcp \
126 test_transport_api_udp \ 134 test_transport_api_udp \
127 test_transport_api_udp_nat \ 135 $(HTTP_PLGUIN_CHECK) \
128 test_plugin_transport_http 136 test_transport_api_udp_nat
129# test_transport_api_http \ 137# test_transport_api_http \
130# TODO: add tests for http, nat, etc. 138# TODO: add tests for http, nat, etc.
131 139