aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 3de46cf6f..9cf16ddb6 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -154,6 +154,7 @@ endif
154 154
155lib_LTLIBRARIES = \ 155lib_LTLIBRARIES = \
156 libgnunettransport.la \ 156 libgnunettransport.la \
157 libgnunettransportaddress.la \
157 libgnunettransportcore.la \ 158 libgnunettransportcore.la \
158 libgnunettransportcommunicator.la \ 159 libgnunettransportcommunicator.la \
159 libgnunettransportmonitor.la \ 160 libgnunettransportmonitor.la \
@@ -197,6 +198,15 @@ libgnunettransport_la_LDFLAGS = \
197 198
198 199
199 200
201libgnunettransportaddress_la_SOURCES = \
202 transport_api2_address.c
203libgnunettransportaddress_la_LIBADD = \
204 $(top_builddir)/src/util/libgnunetutil.la \
205 $(GN_LIBINTL)
206libgnunettransportaddress_la_LDFLAGS = \
207 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
208 -version-info 0:0:0
209
200libgnunettransportcore_la_SOURCES = \ 210libgnunettransportcore_la_SOURCES = \
201 transport_api2_core.c 211 transport_api2_core.c
202libgnunettransportcore_la_LIBADD = \ 212libgnunettransportcore_la_LIBADD = \
@@ -271,7 +281,7 @@ gnunet_communicator_udp_LDADD = \
271 $(top_builddir)/src/nt/libgnunetnt.la \ 281 $(top_builddir)/src/nt/libgnunetnt.la \
272 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 282 $(top_builddir)/src/statistics/libgnunetstatistics.la \
273 $(top_builddir)/src/util/libgnunetutil.la \ 283 $(top_builddir)/src/util/libgnunetutil.la \
274 $(LIBGCRYPT_LIBS) 284 $(LIBGCRYPT_LIBS)
275 285
276 286
277gnunet_helper_transport_wlan_SOURCES = \ 287gnunet_helper_transport_wlan_SOURCES = \
@@ -1339,6 +1349,7 @@ test_transport_api_slow_ats_LDADD = \
1339 1349
1340 1350
1341EXTRA_DIST = \ 1351EXTRA_DIST = \
1352communicator-unix.conf \
1342test_plugin_hostkey \ 1353test_plugin_hostkey \
1343test_plugin_hostkey.ecc \ 1354test_plugin_hostkey.ecc \
1344test_delay \ 1355test_delay \