aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 99fe2d936..7f13db342 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -12,6 +12,9 @@ if HAVE_MHD
12 GN_LIBMHD = -lmicrohttpd 12 GN_LIBMHD = -lmicrohttpd
13 HTTP_SERVER_PLUGIN_LA = libgnunet_plugin_transport_http_server.la 13 HTTP_SERVER_PLUGIN_LA = libgnunet_plugin_transport_http_server.la
14 HTTPS_SERVER_PLUGIN_LA = libgnunet_plugin_transport_https_server.la 14 HTTPS_SERVER_PLUGIN_LA = libgnunet_plugin_transport_https_server.la
15
16 HTTP_SERVER_PLUGIN_TEST = test_plugin_http_server
17 HTTPS_SERVER_PLUGIN_TEST = test_plugin_https_server
15endif 18endif
16 19
17if HAVE_LIBCURL 20if HAVE_LIBCURL
@@ -300,6 +303,8 @@ check_PROGRAMS = \
300 test_plugin_udp \ 303 test_plugin_udp \
301 test_plugin_unix \ 304 test_plugin_unix \
302 $(WLAN_PLUGIN_TEST) \ 305 $(WLAN_PLUGIN_TEST) \
306 $(HTTP_SERVER_PLUGIN_TEST) \
307 $(HTTPS_SERVER_PLUGIN_TEST) \
303 test_transport_api_blacklisting \ 308 test_transport_api_blacklisting \
304 test_transport_api_disconnect_tcp \ 309 test_transport_api_disconnect_tcp \
305 test_transport_api_bidirectional_connect \ 310 test_transport_api_bidirectional_connect \
@@ -470,7 +475,7 @@ test_plugin_unix_LDADD = \
470 $(top_builddir)/src/hello/libgnunethello.la \ 475 $(top_builddir)/src/hello/libgnunethello.la \
471 $(top_builddir)/src/util/libgnunetutil.la \ 476 $(top_builddir)/src/util/libgnunetutil.la \
472 $(top_builddir)/src/transport/libgnunettransporttesting.la 477 $(top_builddir)/src/transport/libgnunettransporttesting.la
473 478
474test_plugin_wlan_SOURCES = \ 479test_plugin_wlan_SOURCES = \
475 test_plugin_transport.c 480 test_plugin_transport.c
476test_plugin_wlan_LDADD = \ 481test_plugin_wlan_LDADD = \
@@ -480,6 +485,24 @@ test_plugin_wlan_LDADD = \
480 $(top_builddir)/src/util/libgnunetutil.la \ 485 $(top_builddir)/src/util/libgnunetutil.la \
481 $(top_builddir)/src/transport/libgnunettransporttesting.la 486 $(top_builddir)/src/transport/libgnunettransporttesting.la
482 487
488test_plugin_http_server_SOURCES = \
489 test_plugin_transport.c
490test_plugin_http_server_LDADD = \
491 $(top_builddir)/src/transport/libgnunettransport.la \
492 $(top_builddir)/src/statistics/libgnunetstatistics.la \
493 $(top_builddir)/src/hello/libgnunethello.la \
494 $(top_builddir)/src/util/libgnunetutil.la \
495 $(top_builddir)/src/transport/libgnunettransporttesting.la
496
497test_plugin_https_server_SOURCES = \
498 test_plugin_transport.c
499test_plugin_https_server_LDADD = \
500 $(top_builddir)/src/transport/libgnunettransport.la \
501 $(top_builddir)/src/statistics/libgnunetstatistics.la \
502 $(top_builddir)/src/hello/libgnunethello.la \
503 $(top_builddir)/src/util/libgnunetutil.la \
504 $(top_builddir)/src/transport/libgnunettransporttesting.la
505
483test_transport_api_tcp_SOURCES = \ 506test_transport_api_tcp_SOURCES = \
484 test_transport_api.c 507 test_transport_api.c
485test_transport_api_tcp_LDADD = \ 508test_transport_api_tcp_LDADD = \