aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am308
1 files changed, 308 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
new file mode 100644
index 000000000..a90b2b793
--- /dev/null
+++ b/src/util/Makefile.am
@@ -0,0 +1,308 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3plugindir = $(libdir)/gnunet
4
5if MINGW
6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols -lole32 -lshell32 -luuid -liconv -lstdc++ -lcomdlg32 -lgdi32
7endif
8
9if USE_COVERAGE
10 AM_CFLAGS = --coverage
11endif
12
13lib_LTLIBRARIES = libgnunetutil.la
14
15libgnunetutil_la_SOURCES = \
16 client.c \
17 common_allocation.c \
18 common_endian.c \
19 common_gettext.c \
20 common_logging.c \
21 configuration.c \
22 container_bloomfilter.c \
23 container_meta_data.c \
24 container_multihashmap.c \
25 crypto_aes.c \
26 crypto_crc.c \
27 crypto_hash.c \
28 crypto_ksk.c \
29 crypto_random.c \
30 crypto_rsa.c \
31 disk.c \
32 getopt.c \
33 getopt_helpers.c \
34 network.c \
35 os_installation.c \
36 os_load.c \
37 os_network.c \
38 os_priority.c \
39 plugin.c \
40 program.c \
41 pseudonym.c \
42 scheduler.c \
43 server.c \
44 server_tc.c \
45 service.c \
46 signal.c \
47 strings.c \
48 time.c
49
50
51libgnunetutil_la_LIBADD = \
52 $(GCLIBADD) \
53 $(LIBGCRYPT_LIBS) \
54 -lgmp -lltdl -lz -lextractor
55
56libgnunetutil_la_LDFLAGS = \
57 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
58 -version-info 4:0:0
59
60
61plugin_LTLIBRARIES = \
62 libgnunet_plugin_test.la
63
64libgnunet_plugin_test_la_SOURCES = \
65 test_plugin_plug.c
66libgnunet_plugin_test_la_LDFLAGS = \
67 $(GN_PLUGIN_LDFLAGS)
68
69
70check_PROGRAMS = \
71 test_client \
72 test_common_allocation \
73 test_common_endian \
74 test_common_logging \
75 test_configuration \
76 test_container_bloomfilter \
77 test_container_meta_data \
78 test_container_multihashmap \
79 test_crypto_aes \
80 test_crypto_aes_weak \
81 test_crypto_crc \
82 test_crypto_hash \
83 test_crypto_ksk \
84 test_crypto_random \
85 test_crypto_rsa \
86 test_disk \
87 test_getopt \
88 test_network \
89 test_network_addressing \
90 test_network_receive_cancel \
91 test_network_timeout \
92 test_network_timeout_no_connect \
93 test_network_transmit_cancel \
94 test_os_load \
95 test_os_network \
96 test_os_priority \
97 test_plugin \
98 test_program \
99 test_pseudonym \
100 test_scheduler \
101 test_scheduler_delay \
102 test_server \
103 test_server_disconnect \
104 test_server_with_client \
105 test_service \
106 test_strings \
107 test_time \
108 perf_crypto_hash
109
110TESTS = $(check_PROGRAMS)
111
112test_client_SOURCES = \
113 test_client.c
114test_client_LDADD = \
115 $(top_builddir)/src/util/libgnunetutil.la
116
117test_common_allocation_SOURCES = \
118 test_common_allocation.c
119test_common_allocation_LDADD = \
120 $(top_builddir)/src/util/libgnunetutil.la
121
122test_common_endian_SOURCES = \
123 test_common_endian.c
124test_common_endian_LDADD = \
125 $(top_builddir)/src/util/libgnunetutil.la
126
127test_common_logging_SOURCES = \
128 test_common_logging.c
129test_common_logging_LDADD = \
130 $(top_builddir)/src/util/libgnunetutil.la
131
132test_configuration_SOURCES = \
133 test_configuration.c
134test_configuration_LDADD = \
135 $(top_builddir)/src/util/libgnunetutil.la
136
137test_container_bloomfilter_SOURCES = \
138 test_container_bloomfilter.c
139test_container_bloomfilter_LDADD = \
140 $(top_builddir)/src/util/libgnunetutil.la
141
142test_container_meta_data_SOURCES = \
143 test_container_meta_data.c
144test_container_meta_data_LDADD = \
145 $(top_builddir)/src/util/libgnunetutil.la
146
147test_container_multihashmap_SOURCES = \
148 test_container_multihashmap.c
149test_container_multihashmap_LDADD = \
150 $(top_builddir)/src/util/libgnunetutil.la
151
152test_crypto_aes_SOURCES = \
153 test_crypto_aes.c
154test_crypto_aes_LDADD = \
155 $(top_builddir)/src/util/libgnunetutil.la
156
157test_crypto_aes_weak_SOURCES = \
158 test_crypto_aes_weak.c
159test_crypto_aes_weak_LDADD = \
160 $(top_builddir)/src/util/libgnunetutil.la
161
162test_crypto_crc_SOURCES = \
163 test_crypto_crc.c
164test_crypto_crc_LDADD = \
165 $(top_builddir)/src/util/libgnunetutil.la
166
167test_crypto_hash_SOURCES = \
168 test_crypto_hash.c
169test_crypto_hash_LDADD = \
170 $(top_builddir)/src/util/libgnunetutil.la
171
172test_crypto_ksk_SOURCES = \
173 test_crypto_ksk.c
174test_crypto_ksk_LDADD = \
175 $(top_builddir)/src/util/libgnunetutil.la
176
177test_crypto_random_SOURCES = \
178 test_crypto_random.c
179test_crypto_random_LDADD = \
180 $(top_builddir)/src/util/libgnunetutil.la
181
182test_crypto_rsa_SOURCES = \
183 test_crypto_rsa.c
184test_crypto_rsa_LDADD = \
185 $(top_builddir)/src/util/libgnunetutil.la
186
187test_disk_SOURCES = \
188 test_disk.c
189test_disk_LDADD = \
190 $(top_builddir)/src/util/libgnunetutil.la
191
192test_getopt_SOURCES = \
193 test_getopt.c
194test_getopt_LDADD = \
195 $(top_builddir)/src/util/libgnunetutil.la
196
197test_network_SOURCES = \
198 test_network.c
199test_network_LDADD = \
200 $(top_builddir)/src/util/libgnunetutil.la
201
202test_network_addressing_SOURCES = \
203 test_network_addressing.c
204test_network_addressing_LDADD = \
205 $(top_builddir)/src/util/libgnunetutil.la
206
207test_network_receive_cancel_SOURCES = \
208 test_network_receive_cancel.c
209test_network_receive_cancel_LDADD = \
210 $(top_builddir)/src/util/libgnunetutil.la
211
212test_network_timeout_SOURCES = \
213 test_network_timeout.c
214test_network_timeout_LDADD = \
215 $(top_builddir)/src/util/libgnunetutil.la
216
217test_network_timeout_no_connect_SOURCES = \
218 test_network_timeout_no_connect.c
219test_network_timeout_no_connect_LDADD = \
220 $(top_builddir)/src/util/libgnunetutil.la
221
222test_network_transmit_cancel_SOURCES = \
223 test_network_transmit_cancel.c
224test_network_transmit_cancel_LDADD = \
225 $(top_builddir)/src/util/libgnunetutil.la
226
227test_os_load_SOURCES = \
228 test_os_load.c
229test_os_load_LDADD = \
230 $(top_builddir)/src/util/libgnunetutil.la
231
232test_os_network_SOURCES = \
233 test_os_network.c
234test_os_network_LDADD = \
235 $(top_builddir)/src/util/libgnunetutil.la
236
237test_os_priority_SOURCES = \
238 test_os_priority.c
239test_os_priority_LDADD = \
240 $(top_builddir)/src/util/libgnunetutil.la
241
242test_plugin_SOURCES = \
243 test_plugin.c
244test_plugin_LDADD = \
245 $(top_builddir)/src/util/libgnunetutil.la
246
247test_program_SOURCES = \
248 test_program.c
249test_program_LDADD = \
250 $(top_builddir)/src/util/libgnunetutil.la
251
252test_pseudonym_SOURCES = \
253 test_pseudonym.c
254test_pseudonym_LDADD = \
255 $(top_builddir)/src/util/libgnunetutil.la
256
257test_scheduler_SOURCES = \
258 test_scheduler.c
259test_scheduler_LDADD = \
260 $(top_builddir)/src/util/libgnunetutil.la
261
262test_scheduler_delay_SOURCES = \
263 test_scheduler_delay.c
264test_scheduler_delay_LDADD = \
265 $(top_builddir)/src/util/libgnunetutil.la
266
267test_server_SOURCES = \
268 test_server.c
269test_server_LDADD = \
270 $(top_builddir)/src/util/libgnunetutil.la
271
272test_server_disconnect_SOURCES = \
273 test_server_disconnect.c
274test_server_disconnect_LDADD = \
275 $(top_builddir)/src/util/libgnunetutil.la
276
277test_server_with_client_SOURCES = \
278 test_server_with_client.c
279test_server_with_client_LDADD = \
280 $(top_builddir)/src/util/libgnunetutil.la
281
282test_service_SOURCES = \
283 test_service.c
284test_service_LDADD = \
285 $(top_builddir)/src/util/libgnunetutil.la
286
287test_strings_SOURCES = \
288 test_strings.c
289test_strings_LDADD = \
290 $(top_builddir)/src/util/libgnunetutil.la
291
292test_time_SOURCES = \
293 test_time.c
294test_time_LDADD = \
295 $(top_builddir)/src/util/libgnunetutil.la
296
297perf_crypto_hash_SOURCES = \
298 perf_crypto_hash.c
299perf_crypto_hash_LDADD = \
300 $(top_builddir)/src/util/libgnunetutil.la
301
302
303EXTRA_DIST = \
304 test_configuration_data.conf \
305 test_container_meta_data_image.jpg \
306 test_program_data.conf \
307 test_pseudonym_data.conf \
308 test_service_data.conf