aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 625ff87a2..0ba06f4bb 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -41,7 +41,7 @@ if USE_COVERAGE
41endif 41endif
42 42
43if ENABLE_BENCHMARK 43if ENABLE_BENCHMARK
44 BENCHMARK = benchmark.c 44 BENCHMARK = benchmark.c benchmark.h
45 PTHREAD = -lpthread 45 PTHREAD = -lpthread
46endif 46endif
47 47
@@ -225,8 +225,13 @@ gnunet_timeout_SOURCES = \
225 gnunet-timeout-w32.c 225 gnunet-timeout-w32.c
226endif 226endif
227 227
228# This is horrible, but compared to the alternatives and the solution
229# which preceded this it is a good compromise and good enough for one
230# file. Everyone else is invited to patch it locally.
228 231
229do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g' 232xENV=$(shell which env)
233
234do_subst = $(SED) -e 's,[@]ENV[@],${xENV},g'
230 235
231gnunet-qr: gnunet-qr.py.in Makefile 236gnunet-qr: gnunet-qr.py.in Makefile
232 $(do_subst) < $(top_srcdir)/src/util/gnunet-qr.py.in > gnunet-qr 237 $(do_subst) < $(top_srcdir)/src/util/gnunet-qr.py.in > gnunet-qr