aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 3a03516db..6c85e4064 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -114,6 +114,11 @@ libgnunet_plugin_test_la_SOURCES = \
114libgnunet_plugin_test_la_LDFLAGS = \ 114libgnunet_plugin_test_la_LDFLAGS = \
115 $(GN_PLUGIN_LDFLAGS) 115 $(GN_PLUGIN_LDFLAGS)
116 116
117if HAVE_BENCHMARKS
118 BENCHMARKS = \
119 perf_crypto_hash
120endif
121
117check_PROGRAMS = \ 122check_PROGRAMS = \
118 test_bio \ 123 test_bio \
119 test_client \ 124 test_client \
@@ -158,10 +163,10 @@ check_PROGRAMS = \
158 test_service \ 163 test_service \
159 test_strings \ 164 test_strings \
160 test_time \ 165 test_time \
161 perf_crypto_hash \ 166 $(BENCHMARKS) \
162 test_os_start_process 167 test_os_start_process
163 168
164if !DISABLE_TEST_RUN 169if ENABLE_TEST_RUN
165TESTS = $(check_PROGRAMS) 170TESTS = $(check_PROGRAMS)
166endif 171endif
167 172