summaryrefslogtreecommitdiff
path: root/README
AgeCommit message (Collapse)Author
2020-05-26remove argon2 dependency. Use limited libsodium argon2id function for GNS ↵Martin Schanzenbach
and NSE
2020-05-17make mhd and jansson mandatory dependenciesMartin Schanzenbach
2020-05-06add libsodium dep to READMEFlorian Dold
2020-04-21purge scrypt; add argon2Martin Schanzenbach
2020-01-01alibi commit to pretend i'm still active on the projectpsyc://loupsycedyglgamf.onion/~lynX
2019-11-17make message about texi2mdoc more clear.ng0
2019-10-27README: fix switch.ng0
2019-10-26conversation is no longer guarded by 'experimental' in theng0
Makefiles. Reflect this in the README.
2019-10-25remove glpk.ng0
2019-10-24rewrite parts of the README.ng0
2019-10-23rewrite note on setuid.ng0
2019-10-23remove never working setuid helper code from the build-system.ng0
refer to the Changelog for a longer reason. In conclusion, this is what people expect, this is what Package Managers patch away for portability, and we can't use install(1) for this because it's not a portable tool.
2019-10-14sort(1) os names.ng0
2019-09-21docs: fix typo 'priviledge'→'privilege'grindhold
2019-09-10small README changes.ng0
2019-09-08README: adjust dependencies and some fixes.ng0
2019-08-16GNUNet->GNUnetng0
2019-06-24partly fixes 0005599, other links do not have a replacementxrs
2019-04-27bump version requirement for MHD to 0.9.63Christian Grothoff
2019-04-20Remove gnunet-download-manager. Fixes #5682ng0
2019-04-13mostly a test commitChristian Grothoff
2019-04-07Add bug id to optional guile dependencyng0
2019-04-03merge conflict resolutionChristian Grothoff
2019-04-03gnunet-qr: Update documentation and scripts to changed dependencies.Hartmut Goebel
Requirement python-zbar is gone, and thus the requirement for Python 2.7. Instead development package for libzbar is required now.
2019-04-01Decrease minimum python version to 3.4ng0
2019-03-20GTK+ is no more, Gimp Toolkit is no more:ng0
https://mail.gnome.org/archives/gtk-devel-list/2019-February/msg00000.html
2019-03-20README: sort dependencies where possibleng0
2019-03-20README: point out that LE is optionalng0
2019-03-15tests do not belong in base descriptionng0
2019-03-13gnunet-qr: Update documentation and scripts to changed dependencies.Hartmut Goebel
Requirement python-zbar is gone, and thus the requirement for Python 2.7. Instead development package for libzbar is required now.
2019-03-12README: style. 2019->futureng0
2019-03-12README: Add TOC. Long enough to be reasonable to add oneng0
2019-03-11fix configure check to test for MHD 0.9.52:Christian Grothoff
2019-03-10Docs: Remove requirement for `python-future`.Hartmut Goebel
This Python module was used nowhere and would not make much sense either: The code is for Python 3.7 which is the most current version of Python and there is no "future" to "backport" to 3.7.
2019-03-10README +libjannsonng0
2019-03-10README: clarify databasesng0
Signed-off-by: ng0 <ng0@n0.is>
2019-03-10README: clarify curlng0
Signed-off-by: ng0 <ng0@n0.is>
2019-03-10README: +awkng0
Signed-off-by: ng0 <ng0@n0.is>
2019-03-10README: +groff,+mandocng0
Signed-off-by: ng0 <ng0@n0.is>
2019-03-09READMEng0
2019-03-03README: URL fix.ng0
2019-02-27README: which in testsng0
2019-02-27README: point out where which(1) is foundng0
2019-02-26No futureng0
2019-02-26README: python2.7 modules optional but required for gnunet-qrng0
2019-02-26README: clarify that ONLY python2.7 is supported for gnunet-qrng0
2019-02-25README clarificationsng0
2019-02-25src/util: Use make 4.0 assignment operatorng0
2019-02-22fix README urlng0
2019-02-22README urlsng0