aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-09-01 18:47:23 +0000
committerChristian Grothoff <christian@grothoff.org>2012-09-01 18:47:23 +0000
commit305acdf03ade1ef83c97f03db7375107943ebd70 (patch)
treed539b7ed0184f683e13f71b7c3a22fdfea01d950 /configure.ac
parenta22321bf1a3187ae9eaf0789ec477f2c9c7d81f7 (diff)
downloadlibmicrohttpd-305acdf03ade1ef83c97f03db7375107943ebd70.tar.gz
libmicrohttpd-305acdf03ade1ef83c97f03db7375107943ebd70.zip
allowing independent enabling/disabling of digest and basic authentication (Mantis #2525)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 23 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5e1d3d7a..7c66c347 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,24 +360,40 @@ AC_MSG_RESULT($enable_https)
360 360
361AM_CONDITIONAL(ENABLE_HTTPS, test "$enable_https" = "yes") 361AM_CONDITIONAL(ENABLE_HTTPS, test "$enable_https" = "yes")
362 362
363# optional: HTTP Basic Auth support. Enabled by default
364AC_MSG_CHECKING(whether to support HTTP basic authentication)
365AC_ARG_ENABLE([bauth],
366 AS_HELP_STRING([--disable-bauth],
367 [disable HTTP basic Auth support]),
368 [enable_bauth=${enableval}],
369 [enable_bauth=yes])
370if test "$enable_bauth" = "yes"
371then
372 AC_DEFINE([BAUTH_SUPPORT],[1],[include basic Auth support])
373else
374 AC_DEFINE([BAUTH_SUPPORT],[0],[disable basic Auth support])
375fi
376AC_MSG_RESULT($enable_bauth)
377AM_CONDITIONAL(ENABLE_BAUTH, [test "x$enable_bauth" != "xno"])
378
363# optional: HTTP Digest Auth support. Enabled by default 379# optional: HTTP Digest Auth support. Enabled by default
364AC_MSG_CHECKING(whether to support HTTP basic and digest authentication) 380AC_MSG_CHECKING(whether to support HTTP digest authentication)
365AC_ARG_ENABLE([dauth], 381AC_ARG_ENABLE([dauth],
366 AS_HELP_STRING([--disable-dauth], 382 AS_HELP_STRING([--disable-dauth],
367 [disable HTTP basic and digest Auth support]), 383 [disable HTTP basic and digest Auth support]),
368 [enable_dauth=${enableval}], 384 [enable_dauth=${enableval}],
369 [enable_dauth=yes]) 385 [enable_dauth=yes])
370
371if test "$enable_dauth" = "yes" 386if test "$enable_dauth" = "yes"
372then 387then
373 AC_DEFINE([DAUTH_SUPPORT],[1],[include basic and digest Auth support]) 388 AC_DEFINE([DAUTH_SUPPORT],[1],[include digest Auth support])
374else 389else
375 AC_DEFINE([DAUTH_SUPPORT],[0],[disable basic and digest Auth support]) 390 AC_DEFINE([DAUTH_SUPPORT],[0],[disable digest Auth support])
376fi 391fi
377AC_MSG_RESULT($enable_dauth) 392AC_MSG_RESULT($enable_dauth)
378
379AM_CONDITIONAL(ENABLE_DAUTH, [test "x$enable_dauth" != "xno"]) 393AM_CONDITIONAL(ENABLE_DAUTH, [test "x$enable_dauth" != "xno"])
380 394
395
396
381MHD_LIB_LDFLAGS="-export-dynamic -no-undefined" 397MHD_LIB_LDFLAGS="-export-dynamic -no-undefined"
382 398
383# TODO insert a proper check here 399# TODO insert a proper check here
@@ -454,7 +470,8 @@ AC_MSG_NOTICE([Configuration Summary:
454 libcurl (testing): ${MSG_CURL} 470 libcurl (testing): ${MSG_CURL}
455 Target directory: ${prefix} 471 Target directory: ${prefix}
456 Messages: ${enable_messages} 472 Messages: ${enable_messages}
457 HTTP Authentic.: ${enable_dauth} 473 Basic auth.: ${enable_bauth}
474 Digest auth.: ${enable_dauth}
458 Postproc: ${enable_postprocessor} 475 Postproc: ${enable_postprocessor}
459 HTTPS support: ${enable_https} 476 HTTPS support: ${enable_https}
460]) 477])