aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2015-03-03 23:42:55 +0000
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2015-03-03 23:42:55 +0000
commit8442f95d1db65bcee7ec9f9e515b4fa812030dbd (patch)
treebd2ee3a59e87ad6afc150fe4d10265bc352c7029 /configure.ac
parent4152f010b2eab67d2f84c1dc69179d6aee6a507d (diff)
downloadlibmicrohttpd-8442f95d1db65bcee7ec9f9e515b4fa812030dbd.tar.gz
libmicrohttpd-8442f95d1db65bcee7ec9f9e515b4fa812030dbd.zip
Check for epoll_create1() function, fix build for Android
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f64e18f4..69e672ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -293,6 +293,18 @@ if test "$enable_epoll" != "no"; then
293 fi 293 fi
294fi 294fi
295 295
296if test "x$enable_epoll" = "xyes"; then
297 AC_CACHE_CHECK([for epoll_create1()], [mhd_cv_have_epoll_create1], [
298 AC_LINK_IFELSE([
299 AC_LANG_PROGRAM([[#include <sys/epoll.h>]], [[
300int fd;
301fd = epoll_create1(EPOLL_CLOEXEC);]])],
302 [mhd_cv_have_epoll_create1=yes],
303 [mhd_cv_have_epoll_create1=no])])
304 AS_IF([test "x$mhd_cv_have_epoll_create1" = "xyes"],[
305 AC_DEFINE([[HAVE_EPOLL_CREATE1]], [[1]], [Define if you have epoll_create1 function.])])
306fi
307
296if test "x$HAVE_POSIX_THREADS" = "xyes"; then 308if test "x$HAVE_POSIX_THREADS" = "xyes"; then
297 # Check for pthread_setname_np() 309 # Check for pthread_setname_np()
298 SAVE_LIBS="$LIBS" 310 SAVE_LIBS="$LIBS"