aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-12-13 21:06:17 +0300
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-12-13 21:06:17 +0300
commit9a6ebcd612b326acb9485b8c9139bd83c67306bc (patch)
tree3109059676cc4ab48ff69fcc7e7ad4040880b738 /configure.ac
parent73b03e9027839a222d5d82e6d7a0fcf2a6d633cf (diff)
downloadlibmicrohttpd-9a6ebcd612b326acb9485b8c9139bd83c67306bc.tar.gz
libmicrohttpd-9a6ebcd612b326acb9485b8c9139bd83c67306bc.zip
Workaround for old broken GnuTLS builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 982e52a7..53657d89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,7 @@ AS_IF([test `uname -s` = "OS/390"],
57# Checks for programs. 57# Checks for programs.
58AC_PROG_AWK 58AC_PROG_AWK
59AC_PROG_GREP 59AC_PROG_GREP
60AC_PROG_FGREP
60AC_PROG_INSTALL 61AC_PROG_INSTALL
61AC_PROG_LN_S 62AC_PROG_LN_S
62AC_PROG_MAKE_SET 63AC_PROG_MAKE_SET
@@ -2597,6 +2598,35 @@ AC_SUBST([GNUTLS_CFLAGS])
2597AC_SUBST([GNUTLS_LDFLAGS]) 2598AC_SUBST([GNUTLS_LDFLAGS])
2598AC_SUBST([GNUTLS_LIBS]) 2599AC_SUBST([GNUTLS_LIBS])
2599 2600
2601AS_VAR_IF([have_gnutls], ["yes"],
2602 [
2603 AC_CACHE_CHECK([for GnuTLS quirks], [mhd_cv_gnutls_mthread_broken],
2604 [
2605 mhd_cv_gnutls_mthread_broken="no"
2606 AS_IF([test -r /etc/redhat-release],
2607 [
2608 AS_IF([$FGREP ' release 6.' /etc/redhat-release >/dev/null || $FGREP '(Santiago)' /etc/redhat-release >/dev/null],
2609 [mhd_cv_gnutls_mthread_broken="found"],
2610 )
2611 ]
2612 )
2613 AS_VAR_IF([mhd_cv_gnutls_mthread_broken], ["no"],
2614 [
2615 AS_IF([command -v rpm >/dev/null],
2616 [
2617 AS_IF([test r`rpm -E '%{rhel} 2>/dev/null'` = "r6"],
2618 [mhd_cv_gnutls_mthread_broken="found"],
2619 )
2620 ]
2621 )
2622 ]
2623 )
2624 ]
2625 )
2626 ]
2627)
2628AM_CONDITIONAL([HAVE_GNUTLS_MTHREAD_BROKEN], [[test "x${mhd_cv_gnutls_mthread_broken}" = "xfound"]])
2629
2600# optional: HTTP Basic Auth support. Enabled by default 2630# optional: HTTP Basic Auth support. Enabled by default
2601AC_MSG_CHECKING([[whether to support HTTP basic authentication]]) 2631AC_MSG_CHECKING([[whether to support HTTP basic authentication]])
2602AC_ARG_ENABLE([bauth], 2632AC_ARG_ENABLE([bauth],