aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-01-24 18:06:18 +0300
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-01-24 18:06:18 +0300
commitc7cbc6cfc0b37bff65879c8b93b120de39dd40b3 (patch)
tree6d7b6fdf97b88007cd42c907584f23d56624b88f /configure.ac
parent7acc854b2bf4c29582bb1b0afaf108ceef4cad9e (diff)
downloadlibmicrohttpd-c7cbc6cfc0b37bff65879c8b93b120de39dd40b3.tar.gz
libmicrohttpd-c7cbc6cfc0b37bff65879c8b93b120de39dd40b3.zip
configure: use proper quoting
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 49aa8589..cb9c90a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,8 +97,8 @@ AM_CONDITIONAL([HAVE_PO], [ test "$have_po" = yes ])
97 97
98# Adam shostack suggests the following for Windows: 98# Adam shostack suggests the following for Windows:
99# -D_FORTIFY_SOURCE=2 -fstack-protector-all 99# -D_FORTIFY_SOURCE=2 -fstack-protector-all
100AC_ARG_ENABLE(gcc-hardening, 100AC_ARG_ENABLE([gcc-hardening],
101 AS_HELP_STRING(--enable-gcc-hardening, enable compiler security checks), 101 [AS_HELP_STRING([--enable-gcc-hardening], [enable compiler security checks])],
102[AS_IF([test x$enableval = xyes],[ 102[AS_IF([test x$enableval = xyes],[
103 CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all" 103 CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all"
104 CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector" 104 CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector"
@@ -108,14 +108,14 @@ AC_ARG_ENABLE(gcc-hardening,
108 108
109# Linker hardening options 109# Linker hardening options
110# Currently these options are ELF specific - you can't use this with MacOSX 110# Currently these options are ELF specific - you can't use this with MacOSX
111AC_ARG_ENABLE(linker-hardening, 111AC_ARG_ENABLE([linker-hardening],
112 AS_HELP_STRING(--enable-linker-hardening, enable linker security fixups), 112 [AS_HELP_STRING([--enable-linker-hardening], [enable linker security fixups])],
113[AS_IF([test x$enableval = xyes], 113[AS_IF([test x$enableval = xyes],
114 [LDFLAGS="$LDFLAGS -z relro -z now"])]) 114 [LDFLAGS="$LDFLAGS -z relro -z now"])])
115 115
116 116
117AC_ARG_ENABLE(sanitizer, 117AC_ARG_ENABLE([sanitizer],
118 AS_HELP_STRING(--enable-sanitizer, enable Address Sanitizer and Undefined Behavior Sanitizer), 118 [AS_HELP_STRING([--enable-sanitizer], [enable Address Sanitizer and Undefined Behavior Sanitizer])],
119[AS_IF([test x$enableval = xyes],[ 119[AS_IF([test x$enableval = xyes],[
120 LDFLAGS="$CFLAGS -fsanitize=address,undefined -fno-omit-frame-pointer" 120 LDFLAGS="$CFLAGS -fsanitize=address,undefined -fno-omit-frame-pointer"
121 ])]) 121 ])])