aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-12-14 18:23:06 +0300
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-12-14 18:23:06 +0300
commitde383203d4d7921bf331510bc898ab88c5844731 (patch)
treeb98bba15684bc005be0fd7aacbfc87aa890161e8 /configure.ac
parent21be8eccb987b6d5fe05d3827ff97c23b8e630cc (diff)
downloadlibmicrohttpd-de383203d4d7921bf331510bc898ab88c5844731.tar.gz
libmicrohttpd-de383203d4d7921bf331510bc898ab88c5844731.zip
Reworked dlltool supported.
* Added support for weakened oversimplified half-broken llvm-dlltool * Streamlined makefile receipts for W32 .dll and related files * Added support for verbose/silent makefile rules * Removed redundant printing from makefile * Added makefile receipts for proper generation of all required files * Silenced MS lib warning * Silenced MS lib invocation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 22 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 998cc385..68f8f0d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1024,7 +1024,25 @@ w32_shared_lib_exp=no
1024AS_IF([test "x$enable_shared" = "xyes" && test "x$os_is_native_w32" = "xyes"], 1024AS_IF([test "x$enable_shared" = "xyes" && test "x$os_is_native_w32" = "xyes"],
1025 [ 1025 [
1026 AS_IF([test "x$ac_cv_use_ms_lib_tool" = "xyes" || test -n "$DLLTOOL"], 1026 AS_IF([test "x$ac_cv_use_ms_lib_tool" = "xyes" || test -n "$DLLTOOL"],
1027 [w32_shared_lib_exp=yes], 1027 [
1028 w32_shared_lib_exp=yes
1029 use_expfile="no"
1030 AS_VAR_IF([ac_cv_use_ms_lib_tool], ["yes"], [use_expfile="yes"],
1031 [
1032 AC_CACHE_CHECK([whether $DLLTOOL supports export file generation], [mhd_cv_dlltool_expfile],
1033 [
1034 AS_IF([AC_RUN_LOG([$DLLTOOL -e conftest.exp >&2 ])],
1035 [
1036 AS_IF([test -f conftest.exp], [mhd_cv_dlltool_expfile="yes"], [mhd_cv_dlltool_expfile="no"])
1037 ], [mhd_cv_dlltool_expfile="no"]
1038 )
1039 rm -f conftest.exp
1040 ]
1041 )
1042 use_expfile="${mhd_cv_dlltool_expfile}"
1043 ]
1044 )
1045 ],
1028 [ 1046 [
1029 AC_MSG_WARN([[GNU dlltool or MS lib.exe is required for creating shared library export on W32]]) 1047 AC_MSG_WARN([[GNU dlltool or MS lib.exe is required for creating shared library export on W32]])
1030 AC_MSG_WARN([[Export library libmicrohttpd.lib will not be created]]) 1048 AC_MSG_WARN([[Export library libmicrohttpd.lib will not be created]])
@@ -1032,8 +1050,9 @@ AS_IF([test "x$enable_shared" = "xyes" && test "x$os_is_native_w32" = "xyes"],
1032 ) 1050 )
1033 ] 1051 ]
1034) 1052)
1035AM_CONDITIONAL(W32_SHARED_LIB_EXP, [test "x$w32_shared_lib_exp" = "xyes"]) 1053AM_CONDITIONAL([W32_SHARED_LIB_EXP], [test "x$w32_shared_lib_exp" = "xyes"])
1036AM_CONDITIONAL(USE_MS_LIB_TOOL, [test "x$ac_cv_use_ms_lib_tool" = "xyes"]) 1054AM_CONDITIONAL([USE_MS_LIB_TOOL], [test "x$ac_cv_use_ms_lib_tool" = "xyes"])
1055AM_CONDITIONAL([USE_EXPORT_FILE], [test "x$use_expfile" = "xyes"])
1037 1056
1038MHD_CHECK_SOCKET_SHUTDOWN_TRIGGER([AC_DEFINE([HAVE_LISTEN_SHUTDOWN],[1],[can use shutdown on listen sockets])]) 1057MHD_CHECK_SOCKET_SHUTDOWN_TRIGGER([AC_DEFINE([HAVE_LISTEN_SHUTDOWN],[1],[can use shutdown on listen sockets])])
1039AM_CONDITIONAL([HAVE_LISTEN_SHUTDOWN], [test "x$mhd_cv_host_shtdwn_trgr_select" = "xyes"]) 1058AM_CONDITIONAL([HAVE_LISTEN_SHUTDOWN], [test "x$mhd_cv_host_shtdwn_trgr_select" = "xyes"])