aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlv-426 <oxcafebaby@yahoo.com>2008-07-20 04:38:41 +0000
committerlv-426 <oxcafebaby@yahoo.com>2008-07-20 04:38:41 +0000
commitf56131958544cff00fac1e2a777df5e08535649a (patch)
treeba003983220afb6f8f706eaf2fc6b41e10ddbff4 /configure.ac
parent04c37e5bd7a82f60127b64338cf37c470ca93e12 (diff)
downloadlibmicrohttpd-f56131958544cff00fac1e2a777df5e08535649a.tar.gz
libmicrohttpd-f56131958544cff00fac1e2a777df5e08535649a.zip
configure.ac: libgcrypt required for HTTPS support
some makefile issues all cURL tests set to use SSLv3 [temporary]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 26 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index d4e85710..69707aba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,30 +207,17 @@ fi
207AM_CONDITIONAL(ENABLE_OPENPGP, test "$enable_openpgp" = "yes") 207AM_CONDITIONAL(ENABLE_OPENPGP, test "$enable_openpgp" = "yes")
208 208
209 209
210# Symbols required by GNU_TLS 210# Libgcrypt linkage : required for HTTPS support
211AC_DEFINE([ENABLE_MINITASN1],[1],[Include minitasn1 support]) 211AC_CHECK_HEADERS(gcrypt.h,gcrypt=true,gcrypt=false)
212AC_DEFINE([GNULIB_GC_HMAC_SHA1],[1],[GNULIB_GC_HMAC_SHA1])
213AC_DEFINE([GNULIB_GC_RANDOM],[1],[GNULIB_GC_RANDOM])
214AC_DEFINE([ENABLE_PKI],[1],[Include ENABLE_OPENPGP support])
215AC_DEFINE([ENABLE_INCLUDED_OPENCDK],[1],[Include ENABLE_INCLUDED_OPENCDK support])
216# gnutls debug support
217AC_DEFINE([DEBUG],[1],[Include gnutls debug message support])
218AC_DEFINE([C99_MACROS],[1],[Include gnutls debug message support])
219
220AC_DEFINE([ENABLE_OPENSSL],[0],[Include ENABLE_OPENSSL support])
221AC_DEFINE([HAVE_LD_OUTPUT_DEF],[0],[Include HAVE_LD_OUTPUT_DEF support])
222AC_DEFINE([HAVE_LD_VERSION_SCRIPT],[0],[Include HAVE_LD_VERSION_SCRIPT support])
223
224# Libgcrypt linkage
225AC_ARG_WITH(libgcrypt, 212AC_ARG_WITH(libgcrypt,
226 [AS_HELP_STRING([--with-libgcrypt=PFX], 213 [AS_HELP_STRING([--with-libgcrypt=PFX],
227 [Base of libgcrypt installation])], 214 [Base of libgcrypt installation])],
228 [AC_MSG_RESULT("$with_libgcrypt") 215 [AC_MSG_RESULT("$with_libgcrypt")
229 case $with_libgcrypt in 216 case $with_libgcrypt in
230 no) 217 no)
218 gcrypt=false
231 ;; 219 ;;
232 yes) 220 yes)
233 AC_CHECK_HEADERS(gcrypt.h,gcrypt=true)
234 ;; 221 ;;
235 *) 222 *)
236 LDFLAGS="-L$with_libgcrypt/lib $LDFLAGS" 223 LDFLAGS="-L$with_libgcrypt/lib $LDFLAGS"
@@ -241,7 +228,8 @@ AC_ARG_WITH(libgcrypt,
241 GCRYPT_LIB_PATH="$with_libgcrypt/lib" 228 GCRYPT_LIB_PATH="$with_libgcrypt/lib"
242 GCRYPT_LDFLAGS="-L$with_libgcrypt/lib" 229 GCRYPT_LDFLAGS="-L$with_libgcrypt/lib"
243 GCRYPT_CPPFLAGS="-I$with_libgcrypt/include" 230 GCRYPT_CPPFLAGS="-I$with_libgcrypt/include"
244 libgcrypt=true)) 231 gcrypt=true,
232 gcrypt=false))
245 LDFLAGS=$SAVE_LDFLAGS 233 LDFLAGS=$SAVE_LDFLAGS
246 CPPFLAGS=$SAVE_CPPFLAGS 234 CPPFLAGS=$SAVE_CPPFLAGS
247 ;; 235 ;;
@@ -257,6 +245,21 @@ AC_SUBST(GCRYPT_LIB_PATH)
257AC_SUBST(GCRYPT_LDFLAGS) 245AC_SUBST(GCRYPT_LDFLAGS)
258AC_SUBST(GCRYPT_CPPFLAGS) 246AC_SUBST(GCRYPT_CPPFLAGS)
259 247
248# Symbols required by GNU_TLS
249AC_DEFINE([ENABLE_MINITASN1],[1],[Include minitasn1 support])
250AC_DEFINE([GNULIB_GC_HMAC_SHA1],[1],[GNULIB_GC_HMAC_SHA1])
251AC_DEFINE([GNULIB_GC_RANDOM],[1],[GNULIB_GC_RANDOM])
252AC_DEFINE([ENABLE_PKI],[1],[Include ENABLE_OPENPGP support])
253AC_DEFINE([ENABLE_INCLUDED_OPENCDK],[1],[Include ENABLE_INCLUDED_OPENCDK support])
254# gnutls debug support
255AC_DEFINE([DEBUG],[1],[Include gnutls debug message support])
256AC_DEFINE([C99_MACROS],[1],[Include gnutls debug message support])
257
258AC_DEFINE([ENABLE_OPENSSL],[0],[Include ENABLE_OPENSSL support])
259AC_DEFINE([HAVE_LD_OUTPUT_DEF],[0],[Include HAVE_LD_OUTPUT_DEF support])
260AC_DEFINE([HAVE_LD_VERSION_SCRIPT],[0],[Include HAVE_LD_VERSION_SCRIPT support])
261
262
260AC_SUBST(CPPFLAGS) 263AC_SUBST(CPPFLAGS)
261AC_SUBST(LIBS) 264AC_SUBST(LIBS)
262AC_SUBST(LDFLAGS) 265AC_SUBST(LDFLAGS)
@@ -293,4 +296,9 @@ AM_CONDITIONAL(ENABLE_INCLUDED_OPENCDK, [test -n "" ] )
293if test "$curl" != 1 296if test "$curl" != 1
294then 297then
295 AC_MSG_NOTICE([WARNING: libcurl not found, testcases cannot be built.]) 298 AC_MSG_NOTICE([WARNING: libcurl not found, testcases cannot be built.])
296fi \ No newline at end of file 299fi
300if test "$gcrypt" != true
301then
302 AC_MSG_NOTICE([WARNING: libgcrypt not found, HTTPS supprot cannot be built.])
303fi
304