aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/https/Makefile.am
diff options
context:
space:
mode:
authorlv-426 <oxcafebaby@yahoo.com>2008-06-22 18:20:35 +0000
committerlv-426 <oxcafebaby@yahoo.com>2008-06-22 18:20:35 +0000
commita0339d2458867dbe9485499265641ff205063445 (patch)
tree055b38828b3696520408a32edf81df5bb37400f0 /src/daemon/https/Makefile.am
parent97c026da05495b83f1511906c2ca027e12ef6cf7 (diff)
downloadlibmicrohttpd-a0339d2458867dbe9485499265641ff205063445.tar.gz
libmicrohttpd-a0339d2458867dbe9485499265641ff205063445.zip
initial GNU TLS import - this should reduce in size considerable
Diffstat (limited to 'src/daemon/https/Makefile.am')
-rw-r--r--src/daemon/https/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/daemon/https/Makefile.am b/src/daemon/https/Makefile.am
new file mode 100644
index 00000000..33f46f1b
--- /dev/null
+++ b/src/daemon/https/Makefile.am
@@ -0,0 +1,34 @@
1SUBDIRS = minitasn1 opencdk openpgp lgl x509 tls .
2
3AM_CPPFLAGS = -I./includes \
4-I$(top_srcdir)/src/daemon/https/lgl \
5-I$(top_srcdir)/src/daemon/https/x509 \
6-I$(top_srcdir)/src/daemon/https/openpgp \
7-I$(top_srcdir)/src/daemon/https/opencdk \
8-I$(top_srcdir)/src/daemon/https/tls \
9-I$(top_srcdir)/src/daemon/https/cfg
10
11noinst_LTLIBRARIES = libhttps.la
12
13libhttps_la_SOURCES = \
14https_common.c \
15errcodes.c
16
17libhttps_la_LIBADD = \
18opencdk/libopencdk.la \
19openpgp/libopenpgp.la \
20x509/libx509.la \
21lgl/liblgl.la \
22tls/libtls.la \
23minitasn1/libasn1.la
24
25#noinst_PROGRAMS = errcodes
26#errcodes_SOURCES = errcodes.c
27#errcodes_LDADD = ../lib/libgnutls.la $(LIBGCRYPT_LIBS) $(LIBTASN1_LIBS)
28
29# gnutls_serv_SOURCES = serv.gaa serv-gaa.h serv-gaa.c list.h serv.c common.h common.c select.c
30# srptool_SOURCES = crypt.gaa crypt-gaa.h crypt-gaa.c crypt.c
31# gnutls_cli_debug_SOURCES = tls_test.gaa tls_test-gaa.h tls_test-gaa.c \
32# tls_test.c tests.h tests.c common.h common.c
33# certtool_SOURCES = certtool.gaa certtool-gaa.h certtool-cfg.h \
34# certtool-gaa.c certtool.c prime.c certtool-cfg.c