aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/https/Makefile.am
diff options
context:
space:
mode:
authorlv-426 <oxcafebaby@yahoo.com>2008-07-14 22:42:32 +0000
committerlv-426 <oxcafebaby@yahoo.com>2008-07-14 22:42:32 +0000
commitdfbd5f48091d0064b765591288b7b542ad58dcb6 (patch)
treef2acea0b8b8c599cb0e6ad8eb9778636b4e03ddc /src/daemon/https/Makefile.am
parenta6a989cf1200f25795e9ec1ed40b21c6024ed53e (diff)
downloadlibmicrohttpd-dfbd5f48091d0064b765591288b7b542ad58dcb6.tar.gz
libmicrohttpd-dfbd5f48091d0064b765591288b7b542ad58dcb6.zip
added authentication test
simplified makefiles support for OpenPGP disabled build
Diffstat (limited to 'src/daemon/https/Makefile.am')
-rw-r--r--src/daemon/https/Makefile.am27
1 files changed, 5 insertions, 22 deletions
diff --git a/src/daemon/https/Makefile.am b/src/daemon/https/Makefile.am
index 4725c405..9ebb2043 100644
--- a/src/daemon/https/Makefile.am
+++ b/src/daemon/https/Makefile.am
@@ -1,26 +1,9 @@
1SUBDIRS = minitasn1 opencdk openpgp lgl x509 tls . 1# placing '.' at the end of SUBDIRS having OPENPGP enabled mixes up build order !
2SUBDIRS = minitasn1 lgl x509 tls
2 3
3AM_CPPFLAGS = \ 4if ENABLE_OPENPGP
4-I$(top_srcdir)/src/include \ 5SUBDIRS += opencdk openpgp
5-I$(top_srcdir)/src/daemon/https/tls \ 6endif
6-I$(top_srcdir)/src/daemon/https/lgl \
7-I$(top_srcdir)/src/daemon/https/x509 \
8-I$(top_srcdir)/src/daemon/https/openpgp \
9-I$(top_srcdir)/src/daemon/https/opencdk \
10-I$(top_srcdir)/src/daemon/https/includes
11
12noinst_LTLIBRARIES = libhttps.la
13
14libhttps_la_SOURCES = \
15https_common.c
16
17libhttps_la_LIBADD = \
18opencdk/libopencdk.la \
19openpgp/libopenpgp.la \
20x509/libx509.la \
21lgl/liblgl.la \
22tls/libtls.la \
23minitasn1/libasn1.la
24 7
25#noinst_PROGRAMS = errcodes 8#noinst_PROGRAMS = errcodes
26#errcodes_SOURCES = errcodes.c 9#errcodes_SOURCES = errcodes.c