aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
authorlv-426 <oxcafebaby@yahoo.com>2008-06-02 02:11:51 +0000
committerlv-426 <oxcafebaby@yahoo.com>2008-06-02 02:11:51 +0000
commit2132000306890e42d48ff535d786d382d14c3985 (patch)
treed4f258960d4ee5295a272e4f000a11575ec68bc2 /src/examples/Makefile.am
parent1a951599f1ece8d91a68a9c9d80188cca241b2e7 (diff)
downloadlibmicrohttpd-2132000306890e42d48ff535d786d382d14c3985.tar.gz
libmicrohttpd-2132000306890e42d48ff535d786d382d14c3985.zip
added X.509 parameters to the daemon struct
added https daemon creation functionality https file server example [overriding existing echo server]
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 189284e2..c42672ab 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -6,6 +6,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
6 6
7noinst_PROGRAMS = \ 7noinst_PROGRAMS = \
8https_server_example \ 8https_server_example \
9https_echo_server_example \
9https_echo_client_example \ 10https_echo_client_example \
10minimal_example \ 11minimal_example \
11querystring_example \ 12querystring_example \
@@ -43,6 +44,18 @@ https_server_example_LDADD = \
43https_server_example_LDFLAGS = \ 44https_server_example_LDFLAGS = \
44 -L$(GNUTLS_LIB_PATH) \ 45 -L$(GNUTLS_LIB_PATH) \
45 -lgnutls 46 -lgnutls
47
48https_echo_server_example_CPPFLAGS = \
49 $(GNUTLS_CPPFLAGS) \
50 -I$(top_srcdir)/src/daemon \
51 -I$(top_srcdir)/src/include
52https_echo_server_example_SOURCES = \
53 https_echo_server_example.c
54https_echo_server_example_LDADD = \
55 $(top_builddir)/src/daemon/libmicrohttpd.la
56https_echo_server_example_LDFLAGS = \
57 -L$(GNUTLS_LIB_PATH) \
58 -lgnutls
46 59
47https_echo_client_example_CPPFLAGS = \ 60https_echo_client_example_CPPFLAGS = \
48 $(GNUTLS_CPPFLAGS) \ 61 $(GNUTLS_CPPFLAGS) \