aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-12-14 22:33:17 +0300
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2021-12-14 22:33:43 +0300
commit21f90d552f5781326f3cb898dc2c56d652b73e14 (patch)
tree961212f5bd47e5083619ae5d00443d6e364963bd /src/microhttpd/Makefile.am
parent65b7612efb61d1dd5a5be286484a306f4145fc25 (diff)
downloadlibmicrohttpd-21f90d552f5781326f3cb898dc2c56d652b73e14.tar.gz
libmicrohttpd-21f90d552f5781326f3cb898dc2c56d652b73e14.zip
Makefile: support silent rules for W32 RC
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index c4d62e97..563a8c28 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -120,9 +120,14 @@ MHD_DLL_RES_LO = libmicrohttpd_la-$(MHD_DLL_RES_SRC:.rc=.lo)
120EXTRA_libmicrohttpd_la_DEPENDENCIES = $(MHD_DLL_RES_LO) 120EXTRA_libmicrohttpd_la_DEPENDENCIES = $(MHD_DLL_RES_LO)
121libmicrohttpd_la_LIBADD += $(MHD_DLL_RES_LO) 121libmicrohttpd_la_LIBADD += $(MHD_DLL_RES_LO)
122 122
123AM_V_RC = $(am__v_RC_$(V))
124am__v_RC_ = $(am__v_RC_$(AM_DEFAULT_VERBOSITY))
125am__v_RC_0 = @echo " RC " $@;
126am__v_RC_1 =
127
123# General rule is not required, but keep it just in case 128# General rule is not required, but keep it just in case
124.rc.lo: 129.rc.lo:
125 $(LIBTOOL) $(AM_V_lt) --tag=RC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(RC) $(RCFLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $< -o $@ 130 $(AM_V_RC) $(LIBTOOL) $(AM_V_lt) --tag=RC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(RC) $(RCFLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $< -o $@
126 131
127# To add dll resource only to .dll file and exclude it form static 132# To add dll resource only to .dll file and exclude it form static
128# lib, a little trick was used. Allow libtool to create file.lo, 133# lib, a little trick was used. Allow libtool to create file.lo,
@@ -133,9 +138,9 @@ libmicrohttpd_la_LIBADD += $(MHD_DLL_RES_LO)
133# Note: windres does not understand '-isystem' flag, so all 138# Note: windres does not understand '-isystem' flag, so all
134# possible '-isystem' flags are replaced by simple '-I' flags. 139# possible '-isystem' flags are replaced by simple '-I' flags.
135$(MHD_DLL_RES_LO): $(MHD_DLL_RES_SRC) 140$(MHD_DLL_RES_LO): $(MHD_DLL_RES_SRC)
136 RC_CPP_FLAGS=" $(DEFAULT_INCLUDES) $(INCLUDES) $(libmicrohttpd_la_CPPFLAGS) $(CPPFLAGS) " && \ 141 $(AM_V_RC) RC_CPP_FLAGS=" $(DEFAULT_INCLUDES) $(INCLUDES) $(libmicrohttpd_la_CPPFLAGS) $(CPPFLAGS) " && \
137 $(LIBTOOL) $(AM_V_lt) --tag=RC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(RC) $(RCFLAGS) $(DEFS) $${RC_CPP_FLAGS// -isystem / -I } $< -o $@ && \ 142 $(LIBTOOL) $(AM_V_lt) --tag=RC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(RC) $(RCFLAGS) $(DEFS) $${RC_CPP_FLAGS// -isystem / -I} $< -o $@ && \
138 echo > $@-empty.c && $(CC) $(AM_CFLAGS) $(CFLAGS) -c $@-empty.c -o $(@:.lo=.o) && rm -f $@-empty.c 143 echo > $@-empty.c && $(CC) $(DEFS) $(AM_CFLAGS) $(CFLAGS) -c $@-empty.c -o $(@:.lo=.o) && rm -f $@-empty.c
139endif 144endif
140 145
141if USE_COVERAGE 146if USE_COVERAGE