aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-07-29 19:23:35 +0200
committerChristian Grothoff <christian@grothoff.org>2019-07-29 19:30:27 +0200
commit40bf201dc53465be1d2805039ef5963a21e44c08 (patch)
treec3cb5639c71dc8d30739c3770d8c7646259a0bc5 /src/microhttpd/Makefile.am
parent1aaff72582b6093f0dcf8c187d125e5fca2d2e8b (diff)
downloadlibmicrohttpd-40bf201dc53465be1d2805039ef5963a21e44c08.tar.gz
libmicrohttpd-40bf201dc53465be1d2805039ef5963a21e44c08.zip
indentation fixes, adding test_upgrade_large.c test for issue reported by Viet
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am34
1 files changed, 30 insertions, 4 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 3fb65fe1..8bc60879 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -165,17 +165,17 @@ check_PROGRAMS = \
165if HAVE_POSIX_THREADS 165if HAVE_POSIX_THREADS
166if ENABLE_UPGRADE 166if ENABLE_UPGRADE
167if USE_POSIX_THREADS 167if USE_POSIX_THREADS
168 check_PROGRAMS += test_upgrade 168 check_PROGRAMS += test_upgrade test_upgrade_large
169endif 169endif
170if USE_W32_THREADS 170if USE_W32_THREADS
171 check_PROGRAMS += test_upgrade 171 check_PROGRAMS += test_upgrade test_upgrade_large
172endif 172endif
173if ENABLE_HTTPS 173if ENABLE_HTTPS
174if USE_POSIX_THREADS 174if USE_POSIX_THREADS
175check_PROGRAMS += test_upgrade_tls 175check_PROGRAMS += test_upgrade_tls test_upgrade_large_tls
176endif 176endif
177if USE_W32_THREADS 177if USE_W32_THREADS
178check_PROGRAMS += test_upgrade_tls 178check_PROGRAMS += test_upgrade_tls test_upgrade_large_tls
179endif 179endif
180endif 180endif
181endif 181endif
@@ -230,6 +230,19 @@ test_upgrade_LDADD = \
230 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \ 230 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
231 $(PTHREAD_LIBS) 231 $(PTHREAD_LIBS)
232 232
233test_upgrade_large_SOURCES = \
234 test_upgrade_large.c test_helpers.h mhd_sockets.h
235test_upgrade_large_CPPFLAGS = \
236 $(AM_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS)
237test_upgrade_large_CFLAGS = \
238 $(AM_CFLAGS) $(PTHREAD_CFLAGS) $(MHD_TLS_LIB_CFLAGS)
239test_upgrade_large_LDFLAGS = \
240 $(MHD_TLS_LIB_LDFLAGS)
241test_upgrade_large_LDADD = \
242 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
243 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
244 $(PTHREAD_LIBS)
245
233test_upgrade_tls_SOURCES = \ 246test_upgrade_tls_SOURCES = \
234 test_upgrade.c test_helpers.h mhd_sockets.h 247 test_upgrade.c test_helpers.h mhd_sockets.h
235test_upgrade_tls_CPPFLAGS = \ 248test_upgrade_tls_CPPFLAGS = \
@@ -243,6 +256,19 @@ test_upgrade_tls_LDADD = \
243 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \ 256 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
244 $(PTHREAD_LIBS) 257 $(PTHREAD_LIBS)
245 258
259test_upgrade_large_tls_SOURCES = \
260 test_upgrade_large.c test_helpers.h mhd_sockets.h
261test_upgrade_large_tls_CPPFLAGS = \
262 $(AM_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS)
263test_upgrade_large_tls_CFLAGS = \
264 $(AM_CFLAGS) $(PTHREAD_CFLAGS) $(MHD_TLS_LIB_CFLAGS)
265test_upgrade_large_tls_LDFLAGS = \
266 $(MHD_TLS_LIB_LDFLAGS)
267test_upgrade_large_tls_LDADD = \
268 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
269 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) \
270 $(PTHREAD_LIBS)
271
246test_postprocessor_SOURCES = \ 272test_postprocessor_SOURCES = \
247 test_postprocessor.c 273 test_postprocessor.c
248test_postprocessor_CPPFLAGS = \ 274test_postprocessor_CPPFLAGS = \