aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-02-19 06:47:35 +0000
committerChristian Grothoff <christian@grothoff.org>2014-02-19 06:47:35 +0000
commit68c667f88b985191a21a308c92d72a7dad172bf2 (patch)
treef46b3e532359e24b4678159cfadd35f6951b6021 /src/microhttpd/Makefile.am
parent745673d704c48aaa719d57132abf2039bcd0169d (diff)
downloadlibmicrohttpd-68c667f88b985191a21a308c92d72a7dad172bf2.tar.gz
libmicrohttpd-68c667f88b985191a21a308c92d72a7dad172bf2.zip
move headers to src/include, build w32functions.c as static library (untested) to make 'make distclean' work cleanly
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index b88e6fa9..3eecb12d 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -1,11 +1,6 @@
1if HAVE_W32
2 W32FUNC_SRC = ../platform/w32functions.c ../platform/w32functions.h
3endif
4
5AM_CPPFLAGS = \ 1AM_CPPFLAGS = \
6 -I$(top_srcdir)/src/include \ 2 -I$(top_srcdir)/src/include \
7 -I$(top_srcdir)/src/microhttpd \ 3 -I$(top_srcdir)/src/microhttpd
8 -I$(top_srcdir)/src/platform
9 4
10AM_CFLAGS = $(HIDDEN_VISIBILITY_CFLAGS) \ 5AM_CFLAGS = $(HIDDEN_VISIBILITY_CFLAGS) \
11 @LIBGCRYPT_CFLAGS@ 6 @LIBGCRYPT_CFLAGS@
@@ -21,13 +16,19 @@ libmicrohttpd_la_SOURCES = \
21 internal.c internal.h \ 16 internal.c internal.h \
22 memorypool.c memorypool.h \ 17 memorypool.c memorypool.h \
23 response.c response.h \ 18 response.c response.h \
24 ../platform/platform_interface.h $(W32FUNC_SRC)
25libmicrohttpd_la_CPPFLAGS = \ 19libmicrohttpd_la_CPPFLAGS = \
26 $(AM_CPPFLAGS) \ 20 $(AM_CPPFLAGS) \
27 -DBUILDING_MHD_LIB=1 21 -DBUILDING_MHD_LIB=1
22libmicrohttpd_la_CFLAGS = \
23 $(AM_CFLAGS) \
24 -DBUILDING_MHD_LIB=1
28libmicrohttpd_la_LDFLAGS = \ 25libmicrohttpd_la_LDFLAGS = \
29 $(MHD_LIB_LDFLAGS) \ 26 $(MHD_LIB_LDFLAGS) \
30 -version-info @LIB_VERSION_CURRENT@:@LIB_VERSION_REVISION@:@LIB_VERSION_AGE@ 27 -version-info @LIB_VERSION_CURRENT@:@LIB_VERSION_REVISION@:@LIB_VERSION_AGE@
28if HAVE_W32
29libmicrohttpd_LDADD =
30 $(top_builddir)/src/platform/libmicrohttpd_w32.la
31endif
31 32
32if USE_COVERAGE 33if USE_COVERAGE
33 AM_CFLAGS += --coverage 34 AM_CFLAGS += --coverage