aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/https/Makefile.am
diff options
context:
space:
mode:
authorEvgeny Grin (Karlson2k) <k2k@narod.ru>2014-04-07 20:50:28 +0000
committerEvgeny Grin (Karlson2k) <k2k@narod.ru>2014-04-07 20:50:28 +0000
commit5fe37b899b0f62e7a6281f34b7921be007e289e2 (patch)
tree6bae258fcced0d94ef7a948cc874df14e66616bf /src/testcurl/https/Makefile.am
parentc196047666c45da71db68f9beebbf605c2d47544 (diff)
downloadlibmicrohttpd-5fe37b899b0f62e7a6281f34b7921be007e289e2.tar.gz
libmicrohttpd-5fe37b899b0f62e7a6281f34b7921be007e289e2.zip
Fix curl HTTPS test with GnuTLS specific version
Diffstat (limited to 'src/testcurl/https/Makefile.am')
-rw-r--r--src/testcurl/https/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/testcurl/https/Makefile.am b/src/testcurl/https/Makefile.am
index 4053e536..f399fc17 100644
--- a/src/testcurl/https/Makefile.am
+++ b/src/testcurl/https/Makefile.am
@@ -4,6 +4,10 @@ if USE_COVERAGE
4 AM_CFLAGS = --coverage 4 AM_CFLAGS = --coverage
5endif 5endif
6 6
7if HAVE_GNUTLS_SNI
8 TEST_HTTPS_SNI = test_https_sni
9endif
10
7CPU_COUNT_DEF = -DCPU_COUNT=$(CPU_COUNT) 11CPU_COUNT_DEF = -DCPU_COUNT=$(CPU_COUNT)
8 12
9AM_CPPFLAGS = \ 13AM_CPPFLAGS = \
@@ -17,7 +21,7 @@ check_PROGRAMS = \
17 test_tls_authentication \ 21 test_tls_authentication \
18 test_https_multi_daemon \ 22 test_https_multi_daemon \
19 test_https_get \ 23 test_https_get \
20 test_https_sni \ 24 $(TEST_HTTPS_SNI) \
21 test_https_get_select \ 25 test_https_get_select \
22 test_https_get_parallel \ 26 test_https_get_parallel \
23 test_https_get_parallel_threads \ 27 test_https_get_parallel_threads \
@@ -32,7 +36,7 @@ TESTS = \
32 test_tls_options \ 36 test_tls_options \
33 test_https_multi_daemon \ 37 test_https_multi_daemon \
34 test_https_get \ 38 test_https_get \
35 test_https_sni \ 39 $(TEST_HTTPS_SNI) \
36 test_https_get_select \ 40 test_https_get_select \
37 test_https_get_parallel \ 41 test_https_get_parallel \
38 test_https_get_parallel_threads \ 42 test_https_get_parallel_threads \
@@ -122,6 +126,7 @@ test_https_get_LDADD = \
122 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 126 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
123 $(GNUTLS_LDFLAGS) $(GNUTLS_LIBS) @LIBGCRYPT_LIBS@ @LIBCURL@ 127 $(GNUTLS_LDFLAGS) $(GNUTLS_LIBS) @LIBGCRYPT_LIBS@ @LIBCURL@
124 128
129if HAVE_GNUTLS_SNI
125test_https_sni_SOURCES = \ 130test_https_sni_SOURCES = \
126 test_https_sni.c \ 131 test_https_sni.c \
127 tls_test_common.c 132 tls_test_common.c
@@ -132,6 +137,7 @@ test_https_sni_LDADD = \
132 $(top_builddir)/src/testcurl/libcurl_version_check.a \ 137 $(top_builddir)/src/testcurl/libcurl_version_check.a \
133 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 138 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
134 $(GNUTLS_LDFLAGS) $(GNUTLS_LIBS) @LIBGCRYPT_LIBS@ @LIBCURL@ 139 $(GNUTLS_LDFLAGS) $(GNUTLS_LIBS) @LIBGCRYPT_LIBS@ @LIBCURL@
140endif
135 141
136test_https_get_select_SOURCES = \ 142test_https_get_select_SOURCES = \
137 test_https_get_select.c \ 143 test_https_get_select.c \