aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/https/Makefile.am
diff options
context:
space:
mode:
authorlv-426 <oxcafebaby@yahoo.com>2008-07-29 03:13:11 +0000
committerlv-426 <oxcafebaby@yahoo.com>2008-07-29 03:13:11 +0000
commita0026eb09eb0b6687ca55a6bf6a019b54f55d330 (patch)
tree32d6819b08f679eecb917e3fc8f9aa5080c0f118 /src/testcurl/https/Makefile.am
parentd7f21bfb62c60566d20b35ea555bf7c6803d9b7b (diff)
downloadlibmicrohttpd-a0026eb09eb0b6687ca55a6bf6a019b54f55d330.tar.gz
libmicrohttpd-a0026eb09eb0b6687ca55a6bf6a019b54f55d330.zip
added debug state dictionary
added secure connection request termination codes secure connections start at MHD_TLS_CONNECTION_INIT
Diffstat (limited to 'src/testcurl/https/Makefile.am')
-rw-r--r--src/testcurl/https/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/testcurl/https/Makefile.am b/src/testcurl/https/Makefile.am
index b88a99df..827b0e7c 100644
--- a/src/testcurl/https/Makefile.am
+++ b/src/testcurl/https/Makefile.am
@@ -10,6 +10,8 @@ AM_CPPFLAGS = \
10$(LIBCURL_CPPFLAGS) 10$(LIBCURL_CPPFLAGS)
11 11
12check_PROGRAMS = \ 12check_PROGRAMS = \
13tls_session_time_out_test \
14tls_cipher_change_test \
13mhds_get_test \ 15mhds_get_test \
14tls_alert_test \ 16tls_alert_test \
15tls_authentication_test \ 17tls_authentication_test \
@@ -18,12 +20,23 @@ mhds_session_info_test
18 20
19TESTS = $(check_PROGRAMS) 21TESTS = $(check_PROGRAMS)
20 22
23tls_session_time_out_test_SOURCES = \
24 tls_session_time_out_test.c
25tls_session_time_out_test_LDADD = \
26 $(top_builddir)/src/testcurl/libcurl_version_check.a \
27 $(top_builddir)/src/daemon/libmicrohttpd.la
28
29tls_cipher_change_test_SOURCES = \
30 tls_cipher_change_test.c
31tls_cipher_change_test_LDADD = \
32 $(top_builddir)/src/testcurl/libcurl_version_check.a \
33 $(top_builddir)/src/daemon/libmicrohttpd.la
34
21tls_alert_test_SOURCES = \ 35tls_alert_test_SOURCES = \
22 tls_alert_test.c 36 tls_alert_test.c
23tls_alert_test_LDADD = \ 37tls_alert_test_LDADD = \
24 $(top_builddir)/src/testcurl/libcurl_version_check.a \ 38 $(top_builddir)/src/testcurl/libcurl_version_check.a \
25 $(top_builddir)/src/daemon/libmicrohttpd.la \ 39 $(top_builddir)/src/daemon/libmicrohttpd.la
26 @LIBCURL@
27 40
28tls_authentication_test_SOURCES = \ 41tls_authentication_test_SOURCES = \
29 tls_authentication_test.c 42 tls_authentication_test.c