aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 35436e7f..cbe609d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,6 +135,30 @@ AC_CHECK_HEADER([[search.h]],
135 135
136AM_CONDITIONAL([MHD_HAVE_TSEARCH], [[test "x$ac_cv_header_search_h" = xyes && test "x$HAVE_TSEARCH" = "x1" && test "x$REPLACE_TSEARCH" != "x1"]]) 136AM_CONDITIONAL([MHD_HAVE_TSEARCH], [[test "x$ac_cv_header_search_h" = xyes && test "x$HAVE_TSEARCH" = "x1" && test "x$REPLACE_TSEARCH" != "x1"]])
137 137
138# Optional headers used for tests
139AC_CHECK_HEADERS([sys/sysctl.h netinet/ip_icmp.h netinet/icmp_var.h], [], [],
140 [[
141#ifdef HAVE_SYS_TYPES_H
142#include <sys/types.h>
143#endif /* HAVE_SYS_TYPES_H */
144#ifdef HAVE_SYS_SYSCTL_H
145#include <sys/sysctl.h>
146#endif /* HAVE_SYS_SYSCTL_H */
147#ifdef HAVE_SYS_SOCKET_H
148#include <sys/socket.h>
149#endif /* HAVE_SYS_SOCKET_H */
150#ifdef HAVE_NETINET_IN_H
151#include <netinet/in.h>
152#endif /* HAVE_NETINET_IN_H */
153#ifdef HAVE_NETINET_IP_H
154#include <netinet/ip.h>
155#endif /* HAVE_NETINET_IP_H */
156#ifdef HAVE_NETINET_IP_ICMP_H
157#include <netinet/ip_icmp.h>
158#endif /* HAVE_NETINET_IP_ICMP_H */
159 ]]
160)
161
138# Checks for gettext. 162# Checks for gettext.
139m4_ifdef([AM_GNU_GETTEXT], [ 163m4_ifdef([AM_GNU_GETTEXT], [
140 AS_VAR_SET_IF([enable_nls], [], [[enable_nls=no]]) 164 AS_VAR_SET_IF([enable_nls], [], [[enable_nls=no]])
@@ -1881,6 +1905,22 @@ AC_MSG_RESULT($have_inet6)
1881 1905
1882MHD_CHECK_FUNC([[sysconf]], [[#include <unistd.h>]], [[long a = sysconf(0); if (a) return 1;]]) 1906MHD_CHECK_FUNC([[sysconf]], [[#include <unistd.h>]], [[long a = sysconf(0); if (a) return 1;]])
1883 1907
1908MHD_CHECK_FUNC([[sysctl]], [[
1909#ifdef HAVE_SYS_TYPES_H
1910#include <sys/types.h>
1911#endif
1912#ifdef HAVE_SYS_SYSCTL_H
1913#include <sys/sysctl.h>
1914#endif
1915#ifdef HAVE_STDDEF_H
1916#include <stddef.h>
1917#endif
1918 ]], [[int mib[2] = {CTL_KERN, KERN_MAXPROC}; if (sysctl(mib, 2, NULL, NULL, NULL, 0)) return 1;]]
1919)
1920
1921MHD_CHECK_FUNC([[usleep]], [[#include <unistd.h>]], [[usleep(100000);]])
1922MHD_CHECK_FUNC([[nanosleep]], [[#include <time.h>]], [[struct timespec ts2, ts1 = {0, 0}; nanosleep(&ts1, &ts2);]])
1923
1884HIDDEN_VISIBILITY_CFLAGS="" 1924HIDDEN_VISIBILITY_CFLAGS=""
1885AS_CASE(["$host"], 1925AS_CASE(["$host"],
1886 [*-*-mingw*],[ 1926 [*-*-mingw*],[