aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 109c184b..419856ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,7 +171,7 @@ AC_SUBST(PTHREAD_CPPFLAGS)
171AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files])) 171AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files]))
172 172
173# Check for optional headers 173# Check for optional headers
174AC_CHECK_HEADERS([sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h netinet/tcp.h time.h sys/socket.h sys/mman.h arpa/inet.h sys/select.h poll.h]) 174AC_CHECK_HEADERS([sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h netinet/tcp.h time.h sys/socket.h sys/mman.h arpa/inet.h sys/select.h poll.h winsock2.h ws2tcpip.h])
175 175
176# Check for plibc.h from system, if not found, use our own 176# Check for plibc.h from system, if not found, use our own
177AC_CHECK_HEADERS([plibc.h],our_private_plibc_h=0,our_private_plibc_h=1) 177AC_CHECK_HEADERS([plibc.h],our_private_plibc_h=0,our_private_plibc_h=1)
@@ -189,6 +189,12 @@ AC_TRY_COMPILE([
189#if HAVE_SYS_SOCKET_H 189#if HAVE_SYS_SOCKET_H
190#include <sys/socket.h> 190#include <sys/socket.h>
191#endif 191#endif
192#if HAVE_WINSOCK2_H
193#include <winsock2.h>
194#endif
195#if HAVE_WS2TCPIP_H
196#include <ws2tcpip.h>
197#endif
192],[ 198],[
193int af=AF_INET6; 199int af=AF_INET6;
194int pf=PF_INET6; 200int pf=PF_INET6;