aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a74e240..60ad6c11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1173,6 +1173,20 @@ AS_VAR_IF([[enable_httpupgrade]],[["yes"]],
1173AM_CONDITIONAL([ENABLE_UPGRADE], [[test "x$enable_httpupgrade" = "xyes"]]) 1173AM_CONDITIONAL([ENABLE_UPGRADE], [[test "x$enable_httpupgrade" = "xyes"]])
1174AC_MSG_RESULT([[$enable_httpupgrade]]) 1174AC_MSG_RESULT([[$enable_httpupgrade]])
1175 1175
1176AC_CACHE_CHECK([[for calloc()]], [[mhd_cv_have_func_calloc]],
1177 [
1178 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1179#include <stdlib.h>
1180 ]],[[void * ptr = calloc(1, 2)]])
1181 ],
1182 [[mhd_cv_have_func_calloc='yes']],
1183 [[mhd_cv_have_func_calloc='no']]
1184 )
1185 ]
1186)
1187AS_VAR_IF([[mhd_cv_have_func_calloc]], [["yes"]],
1188 [AC_DEFINE([[HAVE_CALLOC]], [[1]], [Define to 1 if you have the usable `calloc' function.])])
1189
1176# Check for fork() and waitpid(). They are used for tests. 1190# Check for fork() and waitpid(). They are used for tests.
1177AC_MSG_CHECKING([[for fork()]]) 1191AC_MSG_CHECKING([[for fork()]])
1178AC_LINK_IFELSE( 1192AC_LINK_IFELSE(