aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4da55816..635f7886 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1302,6 +1302,7 @@ AS_VAR_IF([[mhd_cv_have_func_calloc]], [["yes"]],
1302 1302
1303# Check for fork() and waitpid(). They are used for tests. 1303# Check for fork() and waitpid(). They are used for tests.
1304AC_MSG_CHECKING([[for fork()]]) 1304AC_MSG_CHECKING([[for fork()]])
1305mhd_have_fork_waitpid='no'
1305AC_LINK_IFELSE( 1306AC_LINK_IFELSE(
1306 [ 1307 [
1307 AC_LANG_PROGRAM( 1308 AC_LANG_PROGRAM(
@@ -1336,6 +1337,7 @@ AC_LINK_IFELSE(
1336 ], [ 1337 ], [
1337 AC_DEFINE([[HAVE_WAITPID]], [[1]], [Define to 1 if you have the usable `waitpid' function.]) 1338 AC_DEFINE([[HAVE_WAITPID]], [[1]], [Define to 1 if you have the usable `waitpid' function.])
1338 AC_MSG_RESULT([[yes]]) 1339 AC_MSG_RESULT([[yes]])
1340 mhd_have_fork_waitpid='yes'
1339 ],[ 1341 ],[
1340 AC_MSG_RESULT([[no]]) 1342 AC_MSG_RESULT([[no]])
1341 ]) 1343 ])
@@ -1343,6 +1345,7 @@ AC_LINK_IFELSE(
1343 AC_MSG_RESULT([[no]]) 1345 AC_MSG_RESULT([[no]])
1344]) 1346])
1345 1347
1348AM_CONDITIONAL([HAVE_FORK_WAITPID], [test "x$mhd_have_fork_waitpid" = "xyes"])
1346 1349
1347MHD_LIB_LDFLAGS="$MHD_LIB_LDFLAGS -export-dynamic -no-undefined" 1350MHD_LIB_LDFLAGS="$MHD_LIB_LDFLAGS -export-dynamic -no-undefined"
1348 1351