aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b2a53fed..204d32ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,15 +21,15 @@
21# 21#
22# 22#
23AC_PREREQ(2.57) 23AC_PREREQ(2.57)
24AC_INIT([libmicrohttpd], [0.9.3],[libmicrohttpd@gnu.org]) 24AC_INIT([libmicrohttpd], [0.9.4],[libmicrohttpd@gnu.org])
25AM_INIT_AUTOMAKE([libmicrohttpd], [0.9.3]) 25AM_INIT_AUTOMAKE([libmicrohttpd], [0.9.4])
26AM_CONFIG_HEADER([MHD_config.h]) 26AM_CONFIG_HEADER([MHD_config.h])
27AC_CONFIG_MACRO_DIR([m4]) 27AC_CONFIG_MACRO_DIR([m4])
28AH_TOP([#define _GNU_SOURCE 1]) 28AH_TOP([#define _GNU_SOURCE 1])
29 29
30LIB_VERSION_CURRENT=11 30LIB_VERSION_CURRENT=12
31LIB_VERSION_REVISION=0 31LIB_VERSION_REVISION=0
32LIB_VERSION_AGE=1 32LIB_VERSION_AGE=2
33AC_SUBST(LIB_VERSION_CURRENT) 33AC_SUBST(LIB_VERSION_CURRENT)
34AC_SUBST(LIB_VERSION_REVISION) 34AC_SUBST(LIB_VERSION_REVISION)
35AC_SUBST(LIB_VERSION_AGE) 35AC_SUBST(LIB_VERSION_AGE)
@@ -201,7 +201,7 @@ AC_MSG_CHECKING(whether to use libcurl for testing)
201AC_ARG_ENABLE([curl], 201AC_ARG_ENABLE([curl],
202 [AS_HELP_STRING([--disable-curl],[disable cURL based testcases])], 202 [AS_HELP_STRING([--disable-curl],[disable cURL based testcases])],
203 [enable_curl=${enableval}], 203 [enable_curl=${enableval}],
204 [enable_curl=no]) 204 [enable_curl=yes])
205AC_MSG_RESULT($enable_curl) 205AC_MSG_RESULT($enable_curl)
206curl=0 206curl=0
207if test "$enable_curl" = "yes" 207if test "$enable_curl" = "yes"
@@ -230,7 +230,7 @@ AC_ARG_ENABLE([messages],
230 [AS_HELP_STRING([--disable-messages], 230 [AS_HELP_STRING([--disable-messages],
231 [disable MHD error messages])], 231 [disable MHD error messages])],
232 [enable_messages=${enableval}], 232 [enable_messages=${enableval}],
233 [enable_messages=no]) 233 [enable_messages=yes])
234AC_MSG_RESULT($enable_messages) 234AC_MSG_RESULT($enable_messages)
235if test "$enable_messages" = "yes" 235if test "$enable_messages" = "yes"
236then 236then
@@ -246,7 +246,7 @@ AC_ARG_ENABLE([postprocessor],
246 [AS_HELP_STRING([--disable-postprocessor], 246 [AS_HELP_STRING([--disable-postprocessor],
247 [disable MHD PostProcessor functionality])], 247 [disable MHD PostProcessor functionality])],
248 [enable_postprocessor=${enableval}], 248 [enable_postprocessor=${enableval}],
249 [enable_postprocessor=no]) 249 [enable_postprocessor=yes])
250AC_MSG_RESULT($disable_postprocessor) 250AC_MSG_RESULT($disable_postprocessor)
251AM_CONDITIONAL([HAVE_POSTPROCESSOR],test x$enable_postprocessor != xno) 251AM_CONDITIONAL([HAVE_POSTPROCESSOR],test x$enable_postprocessor != xno)
252 252
@@ -305,7 +305,7 @@ AC_ARG_ENABLE([https],
305 [AS_HELP_STRING([--disable-https], 305 [AS_HELP_STRING([--disable-https],
306 [disable HTTPS support])], 306 [disable HTTPS support])],
307 [enable_https=${enableval}], 307 [enable_https=${enableval}],
308 [enable_https=no]) 308 [enable_https=yes])
309if test "$enable_https" = "yes" 309if test "$enable_https" = "yes"
310then 310then
311 if test "$gcrypt" = "true" -a "$gnutls" = "true" 311 if test "$gcrypt" = "true" -a "$gnutls" = "true"
@@ -330,7 +330,7 @@ AC_ARG_ENABLE([dauth],
330 AS_HELP_STRING([--disable-dauth], 330 AS_HELP_STRING([--disable-dauth],
331 [disable HTTP basic and digest Auth support]), 331 [disable HTTP basic and digest Auth support]),
332 [enable_dauth=${enableval}], 332 [enable_dauth=${enableval}],
333 [enable_dauth=no]) 333 [enable_dauth=yes])
334 334
335if test "$enable_dauth" = "yes" 335if test "$enable_dauth" = "yes"
336then 336then
@@ -360,7 +360,7 @@ AC_ARG_ENABLE([coverage],
360 AS_HELP_STRING([--enable-coverage], 360 AS_HELP_STRING([--enable-coverage],
361 [compile the library with code coverage support]), 361 [compile the library with code coverage support]),
362 [use_gcov=${enableval}], 362 [use_gcov=${enableval}],
363 [use_gcov=yes]) 363 [use_gcov=no])
364AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"]) 364AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"])
365 365
366 366