aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 22 insertions, 35 deletions
diff --git a/configure.ac b/configure.ac
index 2076b005..a2d522a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -610,35 +610,30 @@ AC_FUNC_FSEEKO
610AC_CHECK_FUNCS([_lseeki64 lseek64 sendfile64]) 610AC_CHECK_FUNCS([_lseeki64 lseek64 sendfile64])
611 611
612# optional: have error messages ? 612# optional: have error messages ?
613AC_MSG_CHECKING(whether to generate error messages) 613AC_MSG_CHECKING([[whether to generate error messages]])
614AC_ARG_ENABLE([messages], 614AC_ARG_ENABLE([messages],
615 [AS_HELP_STRING([--disable-messages], 615 [AS_HELP_STRING([--disable-messages],
616 [disable MHD error messages])], 616 [disable MHD error messages])],
617 [enable_messages=${enableval}], 617 [enable_messages=${enableval}],
618 [enable_messages=yes]) 618 [enable_messages=yes])
619AC_MSG_RESULT($enable_messages) 619AS_IF([[test "x$enable_messages" = "xyes"]],
620if test "$enable_messages" = "yes" 620 [ AC_DEFINE([HAVE_MESSAGES],[1],[Define to 1 to enable support for error messages.]) ],
621then 621 [[ enable_messages=no ]])
622 AC_DEFINE([HAVE_MESSAGES],[1],[Include error messages]) 622AC_MSG_RESULT([[$enable_messages]])
623else
624 AC_DEFINE([HAVE_MESSAGES],[0],[Disable error messages])
625fi
626 623
627 624
628# optional: have postprocessor? 625# optional: have postprocessor?
629AC_MSG_CHECKING(whether to enable postprocessor) 626AC_MSG_CHECKING([[whether to enable postprocessor]])
630AC_ARG_ENABLE([postprocessor], 627AC_ARG_ENABLE([postprocessor],
631 [AS_HELP_STRING([--disable-postprocessor], 628 [AS_HELP_STRING([--disable-postprocessor],
632 [disable MHD PostProcessor functionality])], 629 [disable MHD PostProcessor functionality])],
633 [enable_postprocessor=${enableval}], 630 [enable_postprocessor=${enableval}],
634 [enable_postprocessor=yes]) 631 [enable_postprocessor=yes])
635test "x$enable_postprocessor" = "xno" || enable_postprocessor=yes 632AS_IF([[test "x$enable_postprocessor" != "xno"]],
633 [ enable_postprocessor=yes
634 AC_DEFINE([HAVE_POSTPROCESSOR],[1],[Define to 1 if libmicrohttpd is compiled with postprocessor support.]) ])
635AM_CONDITIONAL([HAVE_POSTPROCESSOR], [test "x$enable_postprocessor" != "xno"])
636AC_MSG_RESULT([[$enable_postprocessor]]) 636AC_MSG_RESULT([[$enable_postprocessor]])
637AM_CONDITIONAL([HAVE_POSTPROCESSOR],test "x$enable_postprocessor" != "xno")
638if test "x$enable_postprocessor" != "xno"
639then
640 AC_DEFINE([HAVE_POSTPROCESSOR],[1],[define to 1 if MHD was build with postprocessor.c])
641fi
642 637
643 638
644# optional: have zzuf, socat? 639# optional: have zzuf, socat?
@@ -819,38 +814,30 @@ AC_MSG_RESULT([$MSG_HTTPS])
819AM_CONDITIONAL([ENABLE_HTTPS], [test "x$enable_https" = "xyes"]) 814AM_CONDITIONAL([ENABLE_HTTPS], [test "x$enable_https" = "xyes"])
820 815
821# optional: HTTP Basic Auth support. Enabled by default 816# optional: HTTP Basic Auth support. Enabled by default
822AC_MSG_CHECKING(whether to support HTTP basic authentication) 817AC_MSG_CHECKING([[whether to support HTTP basic authentication]])
823AC_ARG_ENABLE([bauth], 818AC_ARG_ENABLE([bauth],
824 AS_HELP_STRING([--disable-bauth], 819 AS_HELP_STRING([--disable-bauth],
825 [disable HTTP basic Auth support]), 820 [disable HTTP basic Auth support]),
826 [enable_bauth=${enableval}], 821 [enable_bauth=${enableval}],
827 [enable_bauth=yes]) 822 [enable_bauth=yes])
828if test "x$enable_bauth" != "xno" 823AS_IF([[test "x$enable_bauth" != "xno"]],
829then 824 [ enable_bauth=yes
830 enable_bauth=yes 825 AC_DEFINE([BAUTH_SUPPORT],[1],[Define to 1 if libmicrohttpd is compiled with basic Auth support.]) ])
831 AC_DEFINE([BAUTH_SUPPORT],[1],[include basic Auth support]) 826AM_CONDITIONAL([ENABLE_BAUTH], [test "x$enable_bauth" != "xno"])
832else 827AC_MSG_RESULT([[$enable_bauth]])
833 AC_DEFINE([BAUTH_SUPPORT],[0],[disable basic Auth support])
834fi
835AC_MSG_RESULT($enable_bauth)
836AM_CONDITIONAL(ENABLE_BAUTH, [test "x$enable_bauth" != "xno"])
837 828
838# optional: HTTP Digest Auth support. Enabled by default 829# optional: HTTP Digest Auth support. Enabled by default
839AC_MSG_CHECKING(whether to support HTTP digest authentication) 830AC_MSG_CHECKING([[whether to support HTTP digest authentication]])
840AC_ARG_ENABLE([dauth], 831AC_ARG_ENABLE([dauth],
841 AS_HELP_STRING([--disable-dauth], 832 AS_HELP_STRING([--disable-dauth],
842 [disable HTTP basic and digest Auth support]), 833 [disable HTTP basic and digest Auth support]),
843 [enable_dauth=${enableval}], 834 [enable_dauth=${enableval}],
844 [enable_dauth=yes]) 835 [enable_dauth=yes])
845if test "x$enable_dauth" != "xno" 836AS_IF([[test "x$enable_dauth" != "xno"]],
846then 837 [ enable_dauth=yes
847 enable_dauth=yes 838 AC_DEFINE([DAUTH_SUPPORT],[1],[Define to 1 if libmicrohttpd is compiled with digest Auth support.]) ])
848 AC_DEFINE([DAUTH_SUPPORT],[1],[include digest Auth support]) 839AM_CONDITIONAL([ENABLE_DAUTH], [test "x$enable_dauth" != "xno"])
849else 840AC_MSG_RESULT([[$enable_dauth]])
850 AC_DEFINE([DAUTH_SUPPORT],[0],[disable digest Auth support])
851fi
852AC_MSG_RESULT($enable_dauth)
853AM_CONDITIONAL(ENABLE_DAUTH, [test "x$enable_dauth" != "xno"])
854 841
855 842
856 843